5 мая 2013 в 07:26

Debian 7

Cостоялся долгожданный выход Debian версии 7.0.



В этой версии произведено множество улучшений как «под капотом», так и видимых конечному пользователю.
Сейчас пакетная база насчитывает более 12800 новых пакетов — таким образом, общее количество пакетов в репозитории составляет 37493. По сравнению со Squeeze, было обновлено 20160 пакетов (70% пакетной базы) и по различным причинам удалено 4125 (14%).

Установка

В установщик внесены следующие изменения:

  • Поддержка UEFI (Secure Boot не поддерживается)
  • Поддержка WPA
  • Установка с помощью голосовых команд
  • Задействование по умолчанию ext4

Софт

Дистрибутив включает в себя следующие версии софта:

  • Linux Kernel 3.2 с собственными патчами
  • X.Org 7.7 (X.Org Server 1.12)
  • GNOME 3.4 (с некоторыми компонентами из 3.2)
  • KDE 4.8.4
  • Xfce 4.8
  • LibreOffice 3.5 (включен по умолчанию и заменяет OpenOffice.org при обновлении)
  • MySQL 5.5
  • Apache 2.2.22
  • Python 2.7
  • GCC 4.7.2
  • LLVM/Clang 3.0
  • Iceweasel (Firefox) 10
  • systemd 44


Multiarch

В Debian 7 произошел переход на multiarch архитектуру. Это означает, что вы сможете устанавливать пакеты сразу нескольких архитектур на одной машине. ia32-libs больше не используется, есть небольшая заметка об этом.

Репозитории

Сервис Debian Backports теперь официально является частью проекта Debian. Для использования бэкпортов нужно подключить следующий репозиторий:
deb http://mirrors.kernel.org/debian wheezy-backports main contrib

Обновление

Инструкция по обновлению с Debian Squeeze
Что нужно знать о Wheezy

Скачать

Debian 7 CD1: amd64 i386
Debian 7 Netinstall: amd64 i386
Debian 7 Netinstall (включает non-free firmware): amd64 i386 multiarch
+117
145935
129
ArtKun 4,1 G+

Комментарии (99)

–33
Jazzis, #
Вот что я поставлю на свой ноут в качестве второй ОСь.
+4
wwarlock, #
А что в качестве первой? )
+3
ftp27, #
Если говорить о порядке, то лучше второй. Сначала венду, а потом линь, дабы лишний раз grub не переустанавливать :)
–13
Jazzis, #
Первой стоит Windows 7, установленная при покупке ноута и обновленная до Максимальной.
+93
maseal, #
Конечно, держите нас в курсе, какие ещё OS Вы собираетесь поставить себе на ноут. Это важно.
+37
backmeupplz, #
Подпишусь на тред. Очень интересно, как обстоят дела у Jazzis.
+79
EugeneOZ, #
Не надо быть такими озлобленными. Вот интересная статья: www.thingist.com/item/4372/
Эти ваши саркастические комментарии отвлекают и занимают места на экране ещё больше, чем тот коммент, который вы критикуете. И полезности в этих сарказмах ещё меньше.
0
ksenobayt, #
Благодарю за линк. Станет отличным аргументом при случае.
+8
JustLuckyGuy, #
Уже даже перевели — habrahabr.ru/post/178747/
+1
mikhanoid, #
В версиях софта явно не хватает версий GCC и Clang/LLVM
+1
ArtKun, #
Спасибо.
Такие вещи лучше писать в ЛС. Топик исправлен, а комментарий остался :)
+10
DenimTornado, #
Ваш тоже остался, так что всё нормально!
+4
ArtKun, #
Теперь их целых три… ой, четыре! :D
+4
Yustos, #
В таблице комментариев уже больше 6 млн записей. Так и int32 можно переполнить. Экономьте идентификаторы!
+1
maksimrussia, #
Занавес закрывается.
0
skomoroh, #
Вот оно счастье, дождался! =)
Теперь можно новый ноут покупать, больше полугода откладывал покупку, ждал до выхода Wheezy.
0
shortcaster, #
не я один такой))
+3
ArtKun, #
А зачем было ждать? Ведь чем новее ноут, тем меньше вероятность, что Wheezy там запустится, ведь не будем отрицать очевидного, софт тут не самый свежий. Я бы наоборот купил раньше и ждал/тестил поддержку железа, чтобы к выходу все уже было вылизано.
0
JagaJaga, #
Расскажите, а в чем причина ожидания? :)
0
firsachi, #
У меня Lenovo E430 c i5 третьего поколения. Виснет постоянно на Wheezy, на выполнении операций копирования. Вышел из положения собрав более свежее ядро.
0
OnYourLips, #
Меня всегда интересовал вопрос: почему они игнорируют минорные версии пакетов от производителей (иссключительно багфиксы), и вместо этого накладывают патчи сами?
Ведь понятно, что пакет от производителей будет заведомо надежней, т.к. они лучше знают что делать, чем мейнтейнеры.
+4
ArtKun, #
Потому что заморозка вполне четко говорит: версии пакетов не менять.
Исключения должны согласовываться с release team, и это делается только в действительно важных случаях.
0
OnYourLips, #
Как обосновывается необновление минорных версий, которые не изменяют поведение или API, а только правят баги?
+5
ArtKun, #
Как обосновывается необновление минорных версий, которые не изменяют поведение или API, а только правят баги?

Думаю, боязнь столкнуться с регрессией и разбираться потом, кто виноват, а ведь это Debian, и регрессиям здесь не рады.

На самом деле, не все так плохо, минорные версии обновляют (до стабилизации дистрибутива, разуемется) и довольно часто — например, обновление nvidia 304.64 -> 304.88 прилетело даже раньше, чем в Fedora.
+5
amarao, #
Потому что нужно различать ситуацию «ставим новое — а оно не умеет» (печаль-беда), и «работало-работало, тут прилетели апдейты и всё нахер поломали, и что мне теперь с этим делать?».

Условно говоря — в дебиане upgrade не будет делать ничего плохого. В отличие от любого дистрибутива, где минорное изменение может привести к мажорному факапу продакт-сервера.
0
g0dlike, #
В RHELоподобных аналогично.
0
amarao, #
Уточним, что в RHEL политика ещё строже — там ядро не меняют ни при каких условиях (и всеми любимый 2.6.18, увешенный бэкпортами по самое немогу, тому доказательство). А вот в «околоRHEL'овских» может быть как получится — зависит от мейнтейнера.
0
g0dlike, #
Уточним:), там не меняют API и ABI, ядро же, как Вы сами заметили, меняется еще и как — к примеру, добавляются новые драйверы и удаляются старые.
Ну, к примеру, у Centos есть 2 ядра — рхеловское эталонное и centosplus, оракл, — тот да, пилит свое ядро.
Мое мнение — почему стоит выбирать RHEL, а не Debian — гарантированные обновления драйверов, ПО и т.д. в течении 10-и лет, при гарантии того, что при обновлении ничего не поломается.
+5
amarao, #
Ну, «гарантия» это громко сказано. А по моим меркам использование голого центоса омерзительно. Нужно подключать epel, а та фагготрия, которая творится в epel'е сводит на нет любые попытки сделать центос стабильным. Так что «протухший, но обильный репозиторий дебиана» лично мне куда удобнее в админстве, чем «не протухший но древний и скудный центос плюс епел, который чуть ли не bleeding edge».

А насчёт «добавления драйверов»… Худшее, что я видел в своей жизни, это когда при смене версии mpt2sas менялся порядок определения дисков. При этом слетали все настройки груба и система становилась если не раком, то попу приподнимала изрядно.

Вообще же, если сервер «есть и работает», то ему нужны только security fix'ы. Идеальный дистрибутив будет таким: берёшь протестированные свежие версии для now(), ставишь сервер и приложения — и дальше тебе эти самые версии саппортят цать лет. Причём разные комплекты (каждый раз свежие при установке сервера).
0
g0dlike, #
По идеальному дистру — 100% согласен.
По поводу «настроек груба» — был когда-то сервер на debian 6 в бета версии — был у него тогда груб 0.97.
При обновлении до релиза установился груб2. При этом сервер перестал загружаться.
Так что у каждой системы есть косяки — все зависит от ровности рук оператора:)
А для чего Вам epel? Набор пакетов — в зависимости от задач. В любом случае, рекомендую использовать приоритеты репозиториев и вдумчивую маскировку пакетов.
+1
amarao, #
Практически все нормальные утилиты и ПО (atop, git, etc) доступны только из epel. У центоса очень маленький репозиторий.
–8
holyorb2, #
В Дебиан 6 был Гном2?
Не понимаю зачем они выпиливают Гном 2 так жестко, почему не оставить его для жаждущих :(
Я в свое время ушел с убунты, как только они выпилили Гном 2 и поставили Гном 3 и Юнити.
Больше всего мне не понятно, как они пришли к выводу что при наличии 6-8Гб оперативы, видеокарты с мощным процем и тоже кучей оперативы, 4х ядерными процессорами… т.е. на современном железе… вводить первые буквы софта для его вызова из меню ?!?!?
Так так, прошло 30 лет и графическое меню «пуск» возвращают к консоли? Грустно, особенно грустно что не дают вариантов для тех кому все же нравиться классический вид Гном 2.

ps. пробовал Гном класик, но это далеко не то. Пробовал ставить отдельно с бубном Гном 2, но это тоже не то. В результате да здравствует МИНТ и Гном 2
+1
ArtKun, #
Для Wheezy есть вполне официальный репозиторий с Mate, который там отлично работает.
0
firsachi, #
Также есть в официальных репозиториях Cinnamon. Мне он больше нравиться чем Gnome3.
0
Throwable, #
Позвольте поинтересоваться, а у Вас не было проблем с Cinnamon? У меня он стабильно кушает память так, что к концу недели приходилось перезагружать комп. Начинал со 128М и доходит до 700-800, тогда как Gnome3 и Unity работают стабильно.
+6
turboNOMAD, #
XFCE попробуйте, он был лучше Гнома2 еще во времена Гнома2, а сейчас и подавно.
0
ksenobayt, #
Скажите, сильно много зависимостей от MATE подтягивается при установке гномо-софта?
Или эти безумные времена, наконец, прошли?
0
turboNOMAD, #
Это от дистрибутива зависит, смотря как мейнтейнер собирал. Я пользуюсь Arch linux, у нас в официальном репозитории вообще нет Мате. Гномовский софт требует ГТК3 да несколько либ от Гнома3.
Как сейчас в Дебиане, не знаю.

Здесь можно посмотреть зависимости любого пакета, если интересно:
packages.debian.org/ru/
0
ArtKun, #
Нет, в Debian с этим проблем никаких, все довольно компактно.
+1
ksenobayt, #
Благодарю, коллеги. Что ж, посмотрю как-нибудь на досуге.
+3
aur, #
В Gnome 3.8 появился classic mode. Он конечно не совсем как в gnome 2, но вполне юзабелен.
Тогда, после первого релиза Unity я, как и многие, пересел на Xfce. Все было хорошо, но я все же долго привыкал, долго выковыривал всякие стандартные приложения xfce, настраивал под себя. Но где-то полгода назад решил все же попробовать поработать в Unity на LTS-версии. Классическое меню помог вернуть Classic Menu Indicator. Нормально, почти привык, но Unity постоянно падала — то композитор отвалится, то дрова нвидиа почему-то перепишут конфиг и сломают композитор, то просто все повиснет (особенно, когда я в каком-нибудь Java-приложении) и только железный ребут помогал. Сейчас, с выходом 13.04 поставил Gnome 3. Пока тоже привыкаю, но есть несколько действительно удобных моментов.

Как консерватор консерватору хочу порекомендовать все же новые оболочки. По последним апдейтам Xfce заметно, что все DE движутся в одну сторону. Кто-то более новаторски (как Gnome), кто-то медленно и вдумчиво внедряет юзабилити-штуки (как Xfce) и рано или поздно придется менять привычки. Например, в 2008 году многие плевались на интерфейс Windows Vista/7, продолжали насиловать труп XP. Сейчас привыкли, обжили семерку, ругаются на Win8.
0
turboNOMAD, #
По последним апдейтам Xfce заметно


Я немного не в курсе, что именно заметно?
Насколько я знаю, последний это 4.10 полуторагодовалой давности, а 4.12 перенесли на неопределенный срок. Или вы о каких-то других апдейтах?
+1
calg0n, #
Поставил на ноут 13.04. Все вроде бы нравится, интерфейс, фичи, все в меру минималистично, но блин постоянно что-то отваливается. Недавно вот упал какой-то демон и у окон пропали заголовки 0_o. Количество падений с каждым релизом все меньше, но если Каноникал пропагандирует Убунту как юзерфрендли систему, то им надо как-то сфокусироваться на стабильности, а не на впиливании новых фич.

А пока у Убунты пока все печально и ни обычные, ни LTS-релизы не могут похвастаться хоть какой-то мало-мальской стабильностью…
+2
mr_avi, #
Пропадание заголовков у окон я наблюдаю в каждой версии еще с 8.04, это самая стабильная «фича» всех убунт.
0
calg0n, #
Эх… если б это было единственная ее проблема — фиг с ней. Но начиная с 11.04 с Убунтой творят что-то невообразимое, курочат как хотят, выпиливают стабильное и проверенное, а вносят никому ненужные unity, wayland, lightdm… Причем по словам разрабов это вроде как должно пойти на пользу, но на самом деле превращают Убунту в нестабильный хлам.
0
juffinhalli, #
А чем Вам Lightdm не угодил?
0
calg0n, #
Как минимум, это еще один велосипед.
0
juffinhalli, #
А чей функционал он дублирует? Слим глюкавый, gdm слишком тяжёлый, kdm для Kde-шников.
0
NetBUG, #
И странные тормоза в UI, которые я не могу объяснить. Ядро работает нормально, но почему-то постоянно есть ощущение, что система подлагивает.
В стоящем рядом Arch примерно с тем же ядром, но с Openbox всё летает, как и должно на Core2Duo.
0
firsachi, #
Я давно заметил, что тестовая ветка Dbian работает куда устойчивее стабильной ветки Ubuntu.
+1
Wedmer, #
Просто Ubuntu это experimental Debian.
0
firsachi, #
Вы заблуждаетесь. Ubuntu это отдельный дистрибутив, который разрабатывается на базе Debian. Использовать пакетную базу другого дистрибутива в мире Linux это нормальное явление.
+1
develop7, #
Как консерватор консерватору хочу порекомендовать все же новые оболочки.
вот бы ещё кто подсказал, как этим оболочкам отбить привычку забирать для собственных нужд <Alt>~.
0
Sartor, #
Linux Mint — это то, что вы искали.
+2
alon, #
Под Hyper-V включены компоненты интеграции или опять ядро пересобирать?
+1
ArtKun, #
Включены бэкпорты из ядра 3.4, все должно работать.
+2
juffinhalli, #
А я не дождался этой версии, работаю теперь на Ubuntu
+1
iwuvjhdva, #
А зачем ждать выхода именно релиза? У меня уже пару лет как на всех машинах wheezy.
0
juffinhalli, #
меня спугнули с wheezy проблемы со стабильностью пакетов, были проблемы с установкой на голое железо. Как пример, именно в wheezy в collectd не работал плагин отправки почты из-за проблем с libsmtp6. А может и сейчас не работает, надо проверять
+6
Ist, #
Я, конечно, не в курсе дел тех, кто использует Debian… Но
Установка с помощью голосовых команд
Зачем?!!!
+61
turboNOMAD, #
Отмена последнего действия по команде «б**ть!». На этапе разбивки диска пока не поддерживается.
0
gasloff, #
Ветку в Баш! )))
+7
Pono, #
Чтобы человек с ограничениями зрения / подвижности рук имел шанс поставить себе ОС.
0
Ulrih, #
Видимо для слабовидящих
+13
iborzenkov, #
Вспоминается старый прикол с баша про то что дебиан еще не вышел, а софт в нем уже старый.
Ну а тут вышел — но софт все равно как минимум полу-годичной давности…
+8
ksenobayt, #
Так блин, юзайте актуальный testing, все так и делают в основе своей.
Я Squeeze никогда не ставил на личную машину, но все сервера у меня на нём.
0
AlexWinner, #
Я Squeeze ставил на ноутбук, но это было в 2010, когда он ещё testing был:)
0
Rezzet, #
Я думал мне показалось.
+1
gunya, #
Скажите это Red Hat, SLES и остальным стабильным дистрибутивам.
Хотите bleeding edge — для вас Fedora, OpenSUSE и ubuntu.
+3
JagaJaga, #
Arch Linux тихо смеется :)
0
vitektm, #
LibreOffice 3.5 считается стабильным? Я думал ветка 3.6 должна быть.
0
ksenobayt, #
Фриз давно был, с тех пор успела и 3.6 стать стабильной.
0
dreamerchant, #
Ну это ж не гном и не ядро, нечетные версии LibreOffice тоже стабильные.
+1
DYPA, #
при установке skype обязательно следует заглянуть сюда wiki.debian.org/skype
+2
greynix, #
Для себя обнаружил удобный Images Autobuilder live.debian.net/, позволяет вносить небольшие корректировки в установочный образ.
0
juffinhalli, #
собирает, но не всегда что заказывал. Не надейтесь на него особо
+24
densss2, #
Выражение «Поставить семёрочку» приобретает новый смысл)))
+1
chersanya, #
Раз Wheezy вышел и стал stable, то следующий Jessie должен был стать новым testing? У меня почему-то новых обновлений не пришло (репозитории указаны testing).
0
andrewsh, #
Подождите, не всё сразу.
0
chersanya, #
Да, действительно, пришло обновление, с размахом можно сказать…
Current status: 211 updates [+211], 2630 new [+2623]. There are 2 newly obsolete packages: lib32v4l-0, libsox-fmt-ffmpeg
+1
divanikus, #
Как-то странно, релиз squeeze был на 8 DVD, а этот всего на 3.
+4
Rene, #
Установка с помощью голосовых команд

Эх, вот раньше было время — из исходников линуксы компилировали.
А теперь, говоришь ему: «Сим-сим, поставься» и вуаля…
:-)
+3
bukt, #
Дебиан релизе :-)
НЛО прилетело и опубликовало эту надпись здесь
0
ArtKun, #
Только что скачал все torrent файлы — проблем нет.
–5
opposite, #
Интересно, на мак встанет без крупных танцев с бубном?..
+2
dreamerchant, #
Дебиан не для ленивых, знаете ли.
+2
GabrielViolet, #
Собственно, сам wheezy
image
+2
Azurius, #
Вот именно такое выражение у меня было когда обновил систему и взгянул на 3й гном (более ранние взгляды на Ubuntu и OpenSuse считал дурным сном и отказывался верить). Хорошо хоть классик вариант есть.
+2
greynix, #
Отдельно хочется сказать спасибо, людям благодаря которым у нас есть русскоязычные Release Notes и Installation Guide.
0
ComodoHacker, #
>Поддержка WPA

Да вы что? Надеюсь, включая WPA2?
0
andrewsh, #
Почему нет?
+1
blueboar2, #
systemd 44


Э… я чего-то не понимаю? Если сейчас уже вышла 200-какая-то версия systemd, то зачем нужна 44я? Я понимаю, что некоторые вообще Systemd не хотят и не любят, но это какое-то половинчатое решение. Либо тогда уж включали бы новый, либо вообще не включали.
+6
dreamerchant, #
После заморозки пакетов релиза ничего не обновляется, если не совсем пожар. Стабильный дебиан — не для десктопов, а для серверов, там нужна стабильность и оттестированность всей совокупности пакетной базы, а не циферки в версии пакета.
0
firsachi, #
Полностью с вами согласен.
0
iXF, #
OrFF одобряет.
0
ProotIK, #
На ноуте и десктопе побежал обновлять с тестинга, а вот на сервере пусть пока постоит squeeze, месяца 2-3…
0
smartseven, #
Все ссылки в разделе «Скачать» ведут на страницу ошибки 404.
0
heathen, #
А самостоятельно найти раздел загрузки на сайте Debian? Начните отсюда, всё-таки почти полгода прошло.

Только зарегистрированные пользователи могут оставлять комментарии. Войдите, пожалуйста.