<!DOCTYPE html>
<html lang="ru" class="no-js">
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta content='width=1024' name='viewport'>
<title>Google Titan — стали известны новые подробности о чипе / Блог компании 1cloud.ru / Хабрахабр</title>

  <meta name="description" content="В марте этого года в Сан-Франциско прошла конференция Google Cloud Next. Компания уделила много внимания безопасности облачной платформы Google.

«Мы внедряем инновации в области безопасности и..." />

  <meta name="keywords" content="1cloud, titan, google, чип" />

  <meta property="fb:app_id" content="444736788986613" />
<meta property="og:locale" content="ru_RU" />
<meta property="og:type" content="article" />
<meta property="fb:pages" content="472597926099084"/>
<meta property="og:url" content="https://habrahabr.ru/company/1cloud/blog/336730/" />
<meta property="og:title" content="Google Titan — стали известны новые подробности о чипе" />

    <meta property="og:image" content="https://habrastorage.org/web/48f/c92/510/48fc925107454a4283615aaffe930a4b.jpg" />
    <link rel="image_src" href="https://habrastorage.org/web/48f/c92/510/48fc925107454a4283615aaffe930a4b.jpg" />
    <meta name="twitter:image" content="https://habrastorage.org/web/48f/c92/510/48fc925107454a4283615aaffe930a4b.jpg">

<meta property="og:description" content="В марте этого года в Сан-Франциско прошла конференция Google Cloud Next. Компания уделила много внимания безопасности облачной платформы Google.  &laquo;Мы внедряем..." />
<meta name="twitter:description" content="В марте этого года в Сан-Франциско прошла конференция Google Cloud Next. Компания уделила много внимания безопасности облачной платформы Google.  &laquo;Мы внедряем...">
<meta name="twitter:title" content="Google Titan — стали известны новые подробности о чипе" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@habrahabr" />
  <meta property="al:android:url" content="habrahabr://post/336730" />
<meta property="al:android:app_name" content="Habrahabr" />
<meta property="al:android:package" content="ru.habrahabr" />
<meta property="al:windows_phone:url" content="habrahabr://post/336730" />
<meta property="al:windows_phone:app_name" content="Habrahabr" />
<meta property="al:windows_phone:app_id" content="460a6bd6-8955-470f-935e-9ea1726a6060" />
  <link rel="canonical" href="https://habrahabr.ru/company/1cloud/blog/336730/"/>
  <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.habrahabr.ru/company/1cloud/blog/336730/" >



<meta name='yandex-verification' content='71593b225aeafc4e' />
<meta name='referrer' content='unsafe-url' />
<meta name="pocket-site-verification" content="ed24b2b9721edf0a282c5b4a3232c4" />


<style type="text/css">
  @font-face{font-family:'Fira Sans';font-style:normal;font-weight:500;src:url(/fonts/0/FiraSans/firaSans-medium.eot);src:local("Fira Sans Medium"),local("FiraSans-Medium"),url(/fonts/0/FiraSans/firaSans-medium.eot?#iefix) format("embedded-opentype"),url(/fonts/0/FiraSans/firaSans-medium.woff2) format("woff2"),url(/fonts/0/FiraSans/firaSans-medium.woff) format("woff"),url(/fonts/0/FiraSans/firaSans-medium.ttf) format("truetype")}
</style>


<link href="https://habracdn.net/habr/styles/1504775151/_build/global_main.css" rel="stylesheet" media="all" />




<meta name='yandex-verification' content='67d46b975fa41645' />

<meta content='Хабрахабр' name='apple-mobile-web-app-title'>

<link rel="apple-touch-icon-precomposed" sizes="57x57" href="/images/favicons/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="/images/favicons/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="/images/favicons/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="/images/favicons/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="/images/favicons/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="/images/favicons/apple-touch-icon-152x152.png" />
<link rel="icon" type="image/png" href="/images/favicons/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="image/png" href="/images/favicons/favicon-16x16.png" sizes="16x16" />
<meta name="application-name" content="Хабрахабр"/>
<meta name="msapplication-TileColor" content="#FFFFFF" />
<meta name="msapplication-TileImage" content="mstile-144x144.png" />

  <link title="Хабрахабр / Блог компании 1cloud.ru / Комментарии к публикации «Google Titan — стали известны новые подробности о чипе»" type="application/rss+xml" rel="alternate" href="https://habrahabr.ru/rss/post/336730/"/>

<script>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</script>

<script src="https://habracdn.net/habr/javascripts/1504775151/libs/jquery-1.8.3.min.js"></script>
  
  <script >var N = 5; var ar_duo1 = Math.floor(Math.random()*N+1);</script>
  <script type="text/javascript" src="https://habracdn.net/habr/javascripts/1504775151/libs/adriver.core.2.js"></script>

<script src="https://habracdn.net/habr/javascripts/1504775151/_parts/advertising.js"></script>
<script type="text/javascript">
  if (typeof adriver == 'undefined'){ var adb1 = 'yes';}

    var user_type = 'guest';

  var page_type = "publish_corp";

  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-726094-1',  'auto');
  ga('create', 'UA-726094-24', 'auto', {'name': 'HGM'});

  ga('require', 'displayfeatures');
  ga('set', 'dimension1', user_type); // user type - guest/readonly/habrauser


  ga('set', 'dimension4', adb1);

  ga('set', 'dimension5', page_type);

  // аккаунт компании
  ga('create', 'UA-35796118-1',  'auto', { 'name': 'company' } );

  ga('company.send', 'pageview'); // Send page view for new tracker.

   (function() {
     var win = window;
     var removeUtms = function(){
       var location = win.location;
       if (location.search.indexOf('utm_') != -1 && history.replaceState) {
         history.replaceState({}, '', window.location.toString().replace(/(\&|\?)utm([_a-z0-9=-]+)/g, ""));
       }
     };
     ga('send', 'pageview', { 'hitCallback': removeUtms });
   })();

  ga('HGM.set', 'dimension1', user_type);
  ga('HGM.set', 'dimension2', "habrahabr");
  ga('HGM.send', 'pageview');
</script>

<script>
  var adcm_config ={
    id:1034,
    platformId: 34,
    
    tags: ['hub_infosecurity', 'g_network_security'],
    init: function () {
      window.adcm.call();
    }
  };
</script>
<script src="https://tag.digitaltarget.ru/adcm.js" async></script>

  </head>

  <body class="nl">
    <div class="layout">
      <div class="layout__row layout__row_services">
        <div id="TMpanel">
  <div class="container">
    <div class="bmenu">
      <a href="https://tmfeed.ru?utm_source=tm_habrahabr&utm_medium=tm_top_panel&utm_campaign=tm_promo">TM Feed</a>
      <a href="https://habrahabr.ru?utm_source=tm_habrahabr&utm_medium=tm_top_panel&utm_campaign=tm_promo" class="current">Хабрахабр</a>
      <a href="https://geektimes.ru?utm_source=tm_habrahabr&utm_medium=tm_top_panel&utm_campaign=tm_promo">Geektimes</a>
      <a href="https://toster.ru?utm_source=tm_habrahabr&utm_medium=tm_top_panel&utm_campaign=tm_promo">Тостер</a>
      <a href="https://moikrug.ru?utm_source=tm_habrahabr&utm_medium=tm_top_panel&utm_campaign=tm_promo">Мой круг</a>
      <a href="https://freelansim.ru?utm_source=tm_habrahabr&utm_medium=tm_top_panel&utm_campaign=tm_promo">Фрилансим</a>
    </div>
  </div>
</div>

      </div>

      <div class="layout__row layout__row_navbar">
        <div class="layout__cell">
          <div class="main-navbar">
  <div class="main-navbar__section main-navbar__section_left">
    <a href="/" class="logo">
      <svg class="icon-svg icon-svg_logo-habrahabr" width="181" height="32" viewBox="0 0 181 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><title>Хабрахабр</title><path d="M24.736 1.044h-8.582L12.53 6.168 8.91 1.044H.325l7.898 11.194L0 23.888h8.583l3.948-5.58 3.95 5.58h8.583l-8.256-11.65zM34.033 7.082c-3.133 0-6.036.88-8.256 2.61l2.87 3.428c1.502-.98 3.754-1.535 5.255-1.535 1.372 0 2.577.36 2.577 2.09v.49c-6.56 0-11.096 1.142-11.096 5.58 0 3.133 2.252 4.633 5.71 4.633 1.665 0 3.885-.913 5.386-2.61v2.12h6.07V12.696c0-4.765-4.73-5.613-8.516-5.613zm2.448 11.455c-.912 1.21-1.89 1.73-2.773 1.73-1.24 0-1.6-.654-1.6-1.274 0-1.533 1.96-2.087 4.373-2.087v1.63zM53.937 8.746c-1.47 0-3.818.62-4.863 1.894.294-2.448 2.023-3.655 5.32-4.308 1.534-.294 5.155-.98 7.18-1.402L60.463 0c-2.546.62-4.864 1.143-7.508 1.633-6.657 1.24-8.125 5.156-8.125 12.14 0 6.658 2.743 10.608 8.813 10.608 5.188 0 8.615-3.426 8.615-8.517 0-3.983-2.87-7.116-8.32-7.116zm-.39 10.28c-1.437 0-2.644-1.24-2.644-2.675s1.207-2.675 2.643-2.675c1.436 0 2.643 1.24 2.643 2.676s-1.208 2.677-2.644 2.677zM74.82 7.082c-1.664 0-3.46 1.044-4.21 2.61v-2.12h-6.07v22.974h6.07v-8.778c.752 1.567 2.546 2.61 4.21 2.61 4.765 0 7.343-3.883 7.343-8.648 0-4.764-2.577-8.647-7.343-8.647zm-1.957 11.552c-.88 0-1.697-.423-2.252-1.108v-3.622c.555-.653 1.373-1.076 2.253-1.076 1.567 0 2.905 1.273 2.905 2.905 0 1.564-1.338 2.902-2.905 2.902zM92.767 7.082c-3.133 0-6.038.88-8.256 2.61l2.872 3.428c1.5-.98 3.753-1.535 5.254-1.535 1.372 0 2.58.36 2.58 2.09v.49c-6.56 0-11.098 1.142-11.098 5.58 0 3.133 2.252 4.633 5.71 4.633 1.665 0 3.885-.913 5.387-2.61v2.12h6.068V12.696c0-4.765-4.732-5.613-8.516-5.613zm2.448 11.455c-.915 1.21-1.894 1.73-2.775 1.73-1.24 0-1.6-.654-1.6-1.274 0-1.533 1.96-2.087 4.375-2.087v1.63zM122.723 7.57h-7.703l-2.055 4.276-2.057-4.275h-7.7l5.58 7.997-5.874 8.32h7.702l2.35-4.306 2.35 4.308h7.702l-6.528-8.32zM132.967 7.082c-3.133 0-6.038.88-8.257 2.61l2.873 3.428c1.503-.98 3.753-1.535 5.255-1.535 1.37 0 2.58.36 2.58 2.09v.49c-6.56 0-11.098 1.142-11.098 5.58 0 3.133 2.252 4.633 5.71 4.633 1.665 0 3.885-.913 5.386-2.61v2.12h6.068V12.696c0-4.765-4.732-5.613-8.516-5.613zm2.448 11.455c-.913 1.21-1.894 1.73-2.775 1.73-1.24 0-1.6-.654-1.6-1.274 0-1.533 1.96-2.087 4.375-2.087v1.63zM152.87 8.746c-1.468 0-3.817.62-4.862 1.894.294-2.448 2.023-3.655 5.32-4.308 1.536-.294 5.157-.98 7.18-1.402L159.397 0c-2.546.62-4.864 1.143-7.506 1.633-6.657 1.24-8.125 5.156-8.125 12.14 0 6.658 2.742 10.608 8.81 10.608 5.19 0 8.617-3.426 8.617-8.517 0-3.983-2.873-7.116-8.323-7.116zm-.39 10.28c-1.437 0-2.643-1.24-2.643-2.675s1.206-2.675 2.643-2.675c1.436 0 2.643 1.24 2.643 2.676 0 1.437-1.207 2.677-2.643 2.677zM173.754 7.082c-1.664 0-3.46 1.044-4.21 2.61v-2.12h-6.07v22.974h6.07v-8.778c.75 1.567 2.546 2.61 4.21 2.61 4.764 0 7.343-3.883 7.343-8.648 0-4.764-2.58-8.647-7.343-8.647zm-1.958 11.552c-.88 0-1.697-.423-2.252-1.108v-3.622c.554-.653 1.37-1.076 2.252-1.076 1.565 0 2.905 1.273 2.905 2.905 0 1.564-1.34 2.902-2.904 2.902z"/></svg>
    </a>
    <ul class="nav-links" id="navbar-links">
  <li class="nav-links__item">
    <a href="/" class="nav-links__item-link ">Публикации</a>
  </li>
  <li class="nav-links__item">
    <a href="/users/" class="nav-links__item-link ">Пользователи</a>
  </li>
  <li class="nav-links__item">
    <a href="/hubs/" class="nav-links__item-link ">Хабы</a>
  </li>
  <li class="nav-links__item">
    <a href="/companies/" class="nav-links__item-link ">Компании</a>
  </li>
  <li class="nav-links__item">
    <a href="/sandbox/" class="nav-links__item-link ">Песочница</a>
  </li>
</ul>
    <form action="/search/#h" method="get" class="search-form" id="search-form">
  <!-- Я вернулся братиш, после стольких лет разлуки:) -->
  <button type="button" class="btn btn_navbar_search icon-svg_search" id="search-form-btn" title="Поиск по сайту">
    <svg class="icon-svg" width="32" height="32" viewBox="0 0 32 32" aria-hidden="true" version="1.1" role="img"><path d="M21.416 13.21c0 4.6-3.65 8.34-8.14 8.34S5.11 17.81 5.11 13.21c0-4.632 3.65-8.373 8.167-8.373 4.488 0 8.14 3.772 8.14 8.372zm1.945 7.083c1.407-2.055 2.155-4.57 2.155-7.084C25.515 6.277 20.04.665 13.277.665S1.04 6.278 1.04 13.21c0 6.93 5.475 12.542 12.237 12.542 2.454 0 4.907-.797 6.942-2.208l7.6 7.79 3.14-3.22-7.6-7.82z"/></svg>
  </button>
  <label class="search-form__field-wrapper">
    <input type="text" name="q" class="search-form__field" id="search-form-field" placeholder="Поиск" tabindex="-1"/>
    <button type="button" class="btn btn_search-close" id="search-form-clear" title="Закрыть">
      <svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>

    </button>
  </label>
</form>

  </div>

  <div class="main-navbar__section main-navbar__section_right">
      <a href="https://habrahabr.ru/auth/login/" id="login" class="btn btn_x-large btn_navbar_login">Войти</a>
      <a href="https://habrahabr.ru/auth/register/" class="btn btn_x-large btn_navbar_registration">Регистрация</a>


  </div>
</div>

        </div>
      </div>

      <div class="layout__row layout__row_body">
        <div class="layout__cell layout__cell_body">
          
              <div class="page-header_bordered page-header_tall">
      <div class="page-header page-header_full" id="company_2921">
  <div class="page-header_wrapper">
    <div class="media-obj media-obj_page-header">
        <a href="/company/1cloud/" class="media-obj__image page-header__image">
            <img src="//habrastorage.org/getpro/habr/company/1af/5c3/6d7/1af5c36d73c8960e356456a7b76294e8.png" width="48" height="48" class="company-info__image-pic"/>
        </a>

      <div class="media-obj__body media-obj__body_page-header">
         <div class="page-header__stats">
          <div class="page-header__stats-value">135,38</div>
          <div class="page-header__stats-label" title="Хабраиндекс - абстрактный показатель популярности компании на Хабрахабре">Рейтинг</div>
        </div>
      </div>
    </div>

  </div>

  <div class="page-header__info">
      <a href="/company/1cloud/" class="page-header__info-title">1cloud.ru</a>
    <div class="page-header__info-desc">
      IaaS, VPS, VDS, Частное и публичное облако, SSL
    </div>
  </div>
</div>

    </div>

  <div class="column-wrapper js-sticky-wrapper">
    <div class="content_left js-content_left">
      <div class="company_post">
        
    <article class="post post_full" id="post_336730">
  <div class="post__wrapper">
    <header class="post__meta">
      <a href="https://habrahabr.ru/users/1cloud/" class="post__user-info user-info" title="Автор публикации">
          <img src="//habrastorage.org/getpro/habr/avatars/046/cda/7c8/046cda7c89b6fb6154d418fd5cd01a87.png" width="24" height="24" class="user-info__image-pic user-info__image-pic_small">
        <span class="user-info__nickname user-info__nickname_small">1cloud</span>
      </a>

      <span class="post__time">сегодня в 10:43</span>

      <a href="https://habrahabr.ru/flows/develop/" class="post__flow" onclick="if (typeof ga === 'function') { ga('send', 'event', 'flow', 'feed page', 'Разработка'); }">Разработка</a>

      
    </header>

    <h1 class="post__title post__title_full">
      <span class="post__title-text">Google Titan — стали известны новые подробности о чипе</span>
    </h1>


      <ul class="post__hubs post__hubs_full-post inline-list">
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habrahabr.ru/hub/infosecurity/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Информационная безопасность'); }">Информационная безопасность</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habrahabr.ru/company/1cloud/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Блог компании 1cloud.ru'); }">Блог компании 1cloud.ru</a>
          </li>
      </ul>

    <ul class="post__marks inline-list"></ul>


    <div class="post__body post__body_full">
      <div class="post__text post__text-html js-mediator-article">В марте этого года в Сан-Франциско прошла конференция Google Cloud Next. Компания <a href="https://www.blog.google/topics/google-cloud/bolstering-security-across-google-cloud/">уделила </a>много внимания безопасности облачной платформы Google.<br>
<br>
«Мы внедряем инновации в области безопасности и хотим, чтобы это стало причиной миграции в облака», — <a href="http://www.zdnet.com/article/google-cloud-unveils-its-custom-security-chip-new-security-features/">сказала</a> Дженнифер Лин (Jennifer Lin), директор по управлению продуктами для Google Cloud Platform (GCP).<br>
<br>
Также Урс Хельцле (Urs Hölzle), старший вице-президент по технической инфраструктуре Google Cloud, презентовал новый чип Titan — он <a href="http://www.businessinsider.com/google-cloud-urs-holzle-2017-3">достал</a> его из серьги, чтобы продемонстрировать, насколько тот мал. В инфраструктуре GCP чип отвечает за надежную аутентификацию пользователя на аппаратном уровне. Google часто <a href="http://www.silicon.co.uk/cloud/datacenter/google-custom-ai-chips-208833?inf_by=595f530d671db8be138b467c">скрывает</a> информацию о своих разработках, но в конце августа компания <a href="http://www.datacenterdynamics.com/content-tracks/security-risk/google-reveals-details-about-titan-its-server-security-chip/98859.fullarticle">раскрыла</a> некоторые подробности о чипе.<br>
<br>
<a href="https://habrahabr.ru/company/1cloud/blog/336730/"><img src="https://habrastorage.org/web/48f/c92/510/48fc925107454a4283615aaffe930a4b.jpg"></a><a name="habracut"></a><br>
<font color="#A9A9A9"><i>/ Flickr / <a href="https://www.flickr.com/photos/websummit/15099289143/in/photolist-p1XsKy-pX9czq-p1dSff-pVoPJs-p1gNBr">Web Summit</a> / <a href="https://creativecommons.org/licenses/by/2.0/">CC</a></i></font><br>
<br>
На создание нового чипа компанию натолкнуло <a href="https://www.blackhat.com/us-17/briefings/schedule/index.html#fractured-backbone-breaking-modern-os-defenses-with-firmware-attacks-7609">увеличение</a> числа взломов программного обеспечения и новых <a href="https://www.blackhat.com/us-17/briefings/schedule/#firmware-is-the-new-black---analyzing-past-three-years-of-biosuefi-security-vulnerabilities-6924">исследований</a> в этой сфере. В Google <a href="https://cloudplatform.googleblog.com/2017/08/Titan-in-depth-security-in-plaintext.html">называют</a> Titan «аппаратным корнем доверия». Он создан инженерами компании с целью заблокировать аппаратные бэкдоры и не дать атакующим использовать уязвимости прошивки для обхода защиты операционной системы. Так, злоумышленники не смогут установить руткиты, которые сохраняются даже после переустановки ОС.<br>
<br>
Titan имеет защищенный прикладной процессор, криптографический сопроцессор, аппаратный генератор случайных чисел, а также иерархическую систему ключей, встроенную статическую RAM (SRAM), флеш-память и ROM.<br>
<br>
<div class="oembed"><div><div style="left: 0; width: 100%; height: 0; position: relative; padding-bottom: 56.2493%;"><iframe src="https://www.youtube.com/embed/kwnWfHq2EfQ?rel=0&amp;showinfo=1&amp;start=1887" style="border: 0; top: 0; left: 0; width: 100%; height: 100%; position: absolute;" allowfullscreen scrolling="no"></iframe></div></div></div><br>
Загрузчик Titan как бы «вклинивается» между прошивкой загрузчика и компонентом, отвечающим за запуск системы — например, BMC — что дает ему возможность исследовать каждый байт прошивки, запускающей системный загрузчик с ОС. При этом он использует криптографию с открытым ключом для проверки собственной прошивки перед загрузкой.<br>
<br>
Кроме того, чип позволяет восстановить прошивку, если появятся ошибки. Он также ведет контрольный журнал любых изменений, внесенных в систему. Titan, используя криптографию, ассоциирует лог-сообщения с последовательно генерируемыми показателями счетчика. Поэтому невозможно <a href="https://news.ycombinator.com/item?id=15093129">незаметно</a> подделать аудит-логи и провести другие нежелательные действия, даже выполненные с root-доступом.<br>
<br>
«Наши компьютеры проводят криптографическую проверку каждого пакета с ПО, а затем решают, стоит ли выдавать ему доступ к ресурсам сети. Titan интегрируется в этот процесс и предлагает дополнительные слои защиты», — резюмирует команда Google.<br>
<br>
Однако несколько резидентов Hacker News высказали опасение касательно того, как компания может доверять чипу, ведь неизвестно, в какой момент отдельные его компоненты окажутся скомпрометированы. Однако в том же <a href="https://news.ycombinator.com/item?id=15093129">треде</a> один из разработчиков проекта отметил, что сам чип и программное обеспечение, которое работает на нем, создаются целиком силами Google (без привлечения сторонних решений), что дает инженерам полный контроль над стеком. <br>
<br>
Что касается физического вмешательства в работу чипа, то, по словам того же разработчика, команда внедрила защитные механизмы, предотвращающие подобные операции и усложняющие реверс-инжиниринг в целом. <br>
<br>
<h2>Новый уровень облачной защиты</h2><br>
В отличие от классических инструментов secure boot, Titan предлагает дополнительные элементы контроля, например, чип выполняет тестирование встроенной памяти (включая ПЗУ) при загрузке, гарантируя её «чистоту» от вредоносных включений.<br>
<br>
«Новый барьер на пути кибератак особенно важен, так как уязвимость прошивки открывает доступ ко всей системе», — так <a href="https://www.welivesecurity.com/2017/07/28/black-hat-hacking-firmware-next-frontier/">отмечали</a> на недавно прошедшей конференции по компьютерной безопасности Black Hat.<br>
<br>
В Google говорят, что Titan можно использовать там, где традиционные подходы secure boot оказываются недоступны или неэффективны. Ожидается, что новый чип пригодится для работы в дата-центрах облачных провайдеров. Titan инициирует постоянные проверки на уровне hardware, которые обеспечивают дополнительную безопасность наряду с программными системами защиты. <br>
<br>
P.S. Еще тройка материалов по теме безопасности из нашего блога:<br>
<br>
<ul>
<li><a href="https://1cloud.ru/blog/security-cloud">Немного о безопасности в «облаке» </a></li>
<li><a href="https://1cloud.ru/blog/cloud-safety-trends">Тренды облачной безопасности</a></li>
<li><a href="https://1cloud.ru/blog/linux-server-security-advices">Как обезопасить Linux-систему: 10 советов</a></li>
</ul></div>
      <script id="js-mpf-mediator-init" data-counter="2820404">!function(e){function t(t,n){if(!(n in e)){for(var r,a=e.document,i=a.scripts,o=i.length;o--;)if(-1!==i[o].src.indexOf(t)){r=i[o];break}if(!r){r=a.createElement("script"),r.type="text/javascript",r.async=!0,r.defer=!0,r.src=t,r.charset="UTF-8";;var d=function(){var e=a.getElementsByTagName("script")[0];e.parentNode.insertBefore(r,e)};"[object Opera]"==e.opera?a.addEventListener?a.addEventListener("DOMContentLoaded",d,!1):e.attachEvent("onload",d):d()} } }t("//top-fwz1.mail.ru/js/code.js","_tmr"),t("//mediator.imgsmail.ru/2/mpf-mediator.min.js","_mediator")}(window);</script>
    </div>

    

    <dl class="defination-list defination-list_tags">
      <dt class="defination-list__label defination-list__label_tags">Метки:</dt>
      <dd class="defination-list__value defination-list__value_tags">    <ul class="inline-list inline-list_fav-tags js-post-tags">
        <li class="inline-list__item inline-list__item_tag"><a href="https://habrahabr.ru/search/?q=%5B1cloud%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">1cloud</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habrahabr.ru/search/?q=%5Btitan%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">titan</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habrahabr.ru/search/?q=%5Bgoogle%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">google</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habrahabr.ru/search/?q=%5B%D1%87%D0%B8%D0%BF%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">чип</a></li>
    </ul>
    <button type="button" class="btn btn_outline_grey btn_mini hidden js-fav-edit-link" data-type="2" data-id="336730" onclick="show_edit_tags(this)">Добавить метки</button>
</dd>
    </dl>
  </div>
</article>


        <form action="/json/favorites/" method="post" class="form form_bordered form_favorites-tags hidden" id="edit_tags_form">
  <input type="hidden" name="action" value="add" />
  <input type="hidden" name="ti" value="0" />
  <input type="hidden" name="tt" value="0" />

  <button type="button" class="btn form__close-btn" onclick="closeForm(this)" title="Закрыть"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

  <fieldset class="form__fieldset">
    <legend class="form__legend">Пометьте публикацию своими метками</legend>
    <input type="text" name="tags_string" class="form__text-field" />
    <span class="form__desc">Метки лучше разделять запятой. Например: <i>программирование, алгоритмы</i></span>
  </fieldset>

  <div class="form__footer">
    <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Сохранить</button>
  </div>
</form>

        <div class="post-additionals">
            <ul class="post-stats post-stats_post js-user_" id="infopanel_post_336730">
        <li class="post-stats__item post-stats__item_voting-wjt">
          <div class="voting-wjt voting-wjt_post js-post-vote" data-id="336730" data-type="2">
            <button type="button" class="btn voting-wjt__button" data-action="plus" onclick="posts_vote(this);" title="Голосовать могут только зарегистрированные пользователи " disabled><span class="icon-svg_arrow-up icon-svg_arrow-medium "><svg class="icon-svg" width="15" height="24" viewBox="0 0 15 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M4.5 24h6v-15h-6v15zm3-24l-7.5 9h15l-7.5-9z"/></svg>
</span></button>

            <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Общий рейтинг 5: &uarr;5 и &darr;0">+5</span>

            <button type="button" class="btn voting-wjt__button" data-action="minus" onclick="posts_vote(this);" title="Голосовать могут только зарегистрированные пользователи  " disabled><span class="icon-svg_arrow-down icon-svg_arrow-medium "><svg class="icon-svg" width="15" height="24" viewBox="0 0 15 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M4.5 24h6v-15h-6v15zm3-24l-7.5 9h15l-7.5-9z"/></svg>
</span></button>
          </div>
        </li>

    <li class="post-stats__item post-stats__item_bookmark">
      <button type="button" class="btn bookmark-btn bookmark-btn_post" data-type="2" data-id="336730" data-action="add" title="Только зарегистрированные пользователи могут добавлять публикации в закладки" onclick="posts_add_to_favorite(this);" disabled>
        <span class="btn_inner"><span class="icon-svg_bookmark "><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="bookmark__counter js-favs_count" title="Количество пользователей, добавивших публикацию в закладки">6</span></span>
      </button>
    </li>

    <li class="post-stats__item post-stats__item_views">
      <div class="post-stats__views" title="Просмотры публикации">
        <span class="icon-svg_views-count"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-stats__views-count">1,2k</span>
      </div>
    </li>

      <li class="post-stats__item post-stats__item_comments">
          <a href="https://habrahabr.ru/company/1cloud/blog/336730/#comments" class="post-stats__comments-link">
            <span class="icon-svg_post-comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-stats__comments-count" title="Читать комментарии">1</span>
          </a>
      </li>





  </ul>

            <form action="/json/complaints/add/" class="form form_bordered form_abuse hidden" method="post" id="abuse_form">
  <input type="hidden" name="tt" value="2" />
  <input type="hidden" name="ti" value="336730" />

  <button type="button" class="btn form__close-btn" onclick="closeForm(this)"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

  <fieldset class="form__fieldset">
    <legend class="form__legend">Нарушение</legend>
    <input type="text" name="text" class="form__text-field" />
    <span class="form__desc">Опишите суть нарушения</span>
  </fieldset>

  <div class="form__footer">
    <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Отправить</button>
  </div>
</form>


              <form action="/conversations/1cloud/" method="GET" class="form form_bordered form_admin-causes hidden" id="admin_causes">

    <input type="hidden" name="moderation" value="336730">

    <button type="button" class="btn form__close-btn" onclick="closeForm(this)"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

    <fieldset class="form__fieldset form__fieldset_admin-causes">
      <legend class="form__legend">Выберите рекомендации для отправки автору:</legend>

      <div class="checkbox-group_columns">
        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="1"/>
          <span class="checkbox__label">Указан только блог</span>
        </label>

        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="2"/>
          <span class="checkbox__label">Орфографические ошибки</span>
        </label>

        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="3"/>
          <span class="checkbox__label">Пунктуационные ошибки</span>
        </label>

        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="4"/>
          <span class="checkbox__label">Отступы</span>
        </label>

        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="5"/>
          <span class="checkbox__label">Текст-простыня</span>
        </label>

        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="6"/>
          <span class="checkbox__label">Короткие предложения</span>
        </label>
        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="7"/>
          <span class="checkbox__label">Смайлики</span>
        </label>
        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="8"/>
          <span class="checkbox__label">Много форматирования</span>
        </label>
        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="9"/>
          <span class="checkbox__label">Картинки</span>
        </label>
        <label class="checkbox checkbox_custom checkbox_recommendation-form">
          <input type="checkbox" class="form__input form__input_checkbox" name="id[]" value="10"/>
          <span class="checkbox__label">Ссылки</span>
        </label>
      </div>
    </fieldset>

    <div class="form__footer">
      <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Отправить</button>
    </div>
  </form>


            <div class="company-info company-info_post-additional">
              <div class="company-info__about">
                <div class="media-obj media-obj_company">
    <a href="/company/1cloud/" class="media-obj__image page-header__image">
        <img src="//habrastorage.org/getpro/habr/company/1af/5c3/6d7/1af5c36d73c8960e356456a7b76294e8.png" width="48" height="48" class="company-info__image-pic"/>
    </a>

  <div class="media-obj__body media-obj__body_page-header media-obj__body_page-header_branding">

    <div class="page-header__info">
        <a href="/company/1cloud/" class="page-header__info-title">1cloud.ru</a>
      <sup class="page-header__stats-value page-header__stats-value_branding" title="Рейтинг компании">135,38</sup>
      <div class="page-header__info-desc">
        IaaS, VPS, VDS, Частное и публичное облако, SSL
      </div>
    </div>
  </div>
</div>


              </div>
              <div class="company-info__author">
                <div class="user-info">
    <div class="user-info__stats">
  <div class="media-obj media-obj_user-info">
    <a href="/users/1cloud/" class="media-obj__image" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_top', 'profile', '1cloud');}">
        <img src="//habrastorage.org/getpro/habr/avatars/046/cda/7c8/046cda7c89b6fb6154d418fd5cd01a87.png" width="48" height="48" class="media-obj__image-pic media-obj__image-pic_user"/>
    </a>

    <div class="media-obj__body media-obj__body_user-info">
          <div class="user-info__stats-item stacked-counter" title="67 голосов">
            <div class="stacked-counter__value stacked-counter__value_green ">9,0</div>
            <div class="stacked-counter__label">Карма</div>
          </div>

        <div class="user-info__stats-item stacked-counter stacked-counter_rating" title="Рейтинг пользователя">
          <div class="stacked-counter__value stacked-counter__value_magenta">62,7</div>
          <div class="stacked-counter__label">Рейтинг</div>
        </div>

        <a href="/users/1cloud/subscription/followers/" class="user-info__stats-item stacked-counter stacked-counter_subscribers" title="Количество подписчиков">
          <div class="stacked-counter__value stacked-counter__value_blue">40</div>
          <div class="stacked-counter__label">Подписчики</div>
        </a>
    </div>
  </div>

</div>


  <div class="user-info__about">
    <div class="user-info__links">
      <a href="/users/1cloud/" class="user-info__nickname user-info__nickname_doggy" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_top', 'profile', '1cloud');}">1cloud</a>
      
    </div>

      <div class="user-info__specialization">Пользователь</div>
  </div>

</div>

              </div>
                  <ul class="company-info__contacts inline-list">
          <li class="inline-list__item inline-list__item_contact-link"><a href="https://1cloud.ru/" target="_blank">Сайт</a></li>
          <li class="inline-list__item inline-list__item_contact-link"><a href="http://facebook.com/1cloudru" target="_blank">Facebook</a></li>
          <li class="inline-list__item inline-list__item_contact-link"><a href="http://vk.com/1cloud" target="_blank">Вконтакте</a></li>
    </ul>

            </div>
            <div class="post-share">
  <span class="post-share__title">Поделиться публикацией</span>
  <ul class="post-share__buttons social-icons">
    <li class="social-icons__item social-icons__item_post">
      <a href="https://www.facebook.com/sharer/sharer.php?u=https://habrahabr.ru/company/1cloud/blog/336730/"
        class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_facebook"
        title="Опубликовать ссылку в Facebook"
        onclick="window.open(this.href, 'Опубликовать ссылку в Facebook', 'width=640,height=436,toolbar=0,status=0'); return false"
      >
        <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M14.889 8.608h-1.65c-.195 0-.413.257-.413.6v1.192h2.063v1.698h-2.063v5.102h-1.948v-5.102h-1.766v-1.698h1.766v-1c0-1.434.995-2.6 2.361-2.6h1.65v1.808z"/></svg>
      </a>
    </li>
    <li class="social-icons__item social-icons__item_post">
      <a href="https://twitter.com/intent/tweet?text=Google+Titan+%E2%80%94+%D1%81%D1%82%D0%B0%D0%BB%D0%B8+%D0%B8%D0%B7%D0%B2%D0%B5%D1%81%D1%82%D0%BD%D1%8B+%D0%BD%D0%BE%D0%B2%D1%8B%D0%B5+%D0%BF%D0%BE%D0%B4%D1%80%D0%BE%D0%B1%D0%BD%D0%BE%D1%81%D1%82%D0%B8+%D0%BE+%D1%87%D0%B8%D0%BF%D0%B5+https://habr.ru/p/336730/+via+%40habrahabr"
        class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_twitter"
        title="Опубликовать ссылку в Twitter"
        onclick="window.open(this.href, 'Опубликовать ссылку в Twitter', 'width=800,height=300,resizable=yes,toolbar=0,status=0'); return false"
      >
        <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.414 8.642c-.398.177-.826.296-1.276.35.459-.275.811-.71.977-1.229-.43.254-.905.439-1.41.539-.405-.432-.982-.702-1.621-.702-1.227 0-2.222.994-2.222 2.222 0 .174.019.344.058.506-1.846-.093-3.484-.978-4.579-2.322-.191.328-.301.71-.301 1.117 0 .77.392 1.45.988 1.849-.363-.011-.706-.111-1.006-.278v.028c0 1.077.766 1.974 1.782 2.178-.187.051-.383.078-.586.078-.143 0-.282-.014-.418-.04.282.882 1.103 1.525 2.075 1.542-.76.596-1.718.951-2.759.951-.179 0-.356-.01-.53-.031.983.63 2.15.998 3.406.998 4.086 0 6.321-3.386 6.321-6.321l-.006-.287c.433-.314.81-.705 1.107-1.15z"/></svg>
      </a>
    </li>
    <li class="social-icons__item social-icons__item_post">
      <a href="https://vk.com/share.php?url=https://habrahabr.ru/company/1cloud/blog/336730/"
        class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_vkontakte"
        title="Опубликовать ссылку во ВКонтакте"
        onclick="window.open(this.href, 'Опубликовать ссылку во Вконтакте', 'width=800,height=300,toolbar=0,status=0'); return false"
      >
        <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M16.066 11.93s1.62-2.286 1.782-3.037c.054-.268-.064-.418-.343-.418h-1.406c-.322 0-.44.139-.537.343 0 0-.76 1.619-1.685 2.64-.297.33-.448.429-.612.429-.132 0-.193-.11-.193-.408v-2.607c0-.365-.043-.472-.343-.472h-2.254c-.172 0-.279.1-.279.236 0 .343.526.421.526 1.352v1.921c0 .386-.022.537-.204.537-.483 0-1.631-1.663-2.274-3.552-.129-.386-.268-.494-.633-.494h-1.406c-.204 0-.354.139-.354.343 0 .375.44 2.114 2.167 4.442 1.159 1.566 2.683 2.414 4.056 2.414.838 0 1.041-.139 1.041-.494v-1.202c0-.301.118-.429.29-.429.193 0 .534.062 1.33.848.945.901 1.01 1.276 1.525 1.276h1.578c.161 0 .311-.075.311-.343 0-.354-.462-.987-1.17-1.738-.29-.386-.762-.805-.912-.998-.215-.226-.151-.354-.001-.59z"/></svg>
      </a>
    </li>
    <li class="social-icons__item social-icons__item_post">
      <a href="https://t.me/share/url?url=https://habrahabr.ru/company/1cloud/blog/336730/&title=Google Titan — стали известны новые подробности о чипе"
        class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_telegram"
        title="Поделиться ссылкой в Telegram"
        onclick="window.open(this.href, 'Поделиться ссылкой в Telegram', 'width=800,height=300,toolbar=0,status=0'); return false"
      >
        <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.17 7.621l-10.498 3.699c-.169.059-.206.205-.006.286l2.257.904 1.338.536 6.531-4.796s.189.057.125.126l-4.68 5.062-.27.299.356.192 2.962 1.594c.173.093.397.016.447-.199.058-.254 1.691-7.29 1.728-7.447.047-.204-.087-.328-.291-.256zm-6.922 8.637c0 .147.082.188.197.084l1.694-1.522-1.891-.978v2.416z"/></svg>
      </a>
    </li>
    <li class="social-icons__item social-icons__item_post">
      <a href="https://getpocket.com/edit?url=https://habrahabr.ru/company/1cloud/blog/336730/&title=Google Titan — стали известны новые подробности о чипе"
        class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_pocket"
        title="Добавить ссылку в Pocket"
        target="_blank"
      >
      </a>
    </li>
  </ul>
</div>

        </div>

        

          

    <div class="default-block default-block_content">
      <div class="default-block__header default-block__header_large">
        <span class="default-block__header-title default-block__header-title_large">Похожие публикации</span>
      </div>
      <div class="default-block__content">

        <ul class="content-list">
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date"> 3 марта 2016 в 14:50</span>
              <a href="/post/278479/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common'); }">Фотоэкскурсия по «облаку» компании 1cloud</a>

              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span>
                      <span class="post-info__meta-counter">+9</span>
                </span>
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">9,6k</span>
                </span>
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_star"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">24</span>
                </span>
                <a href="/post/278479#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">2</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">29 февраля 2016 в 10:01</span>
              <a href="/post/278055/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common'); }">Немного о хранении данных и опыте 1cloud</a>

              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span>
                      <span class="post-info__meta-counter">+9</span>
                </span>
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">11,6k</span>
                </span>
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_star"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">22</span>
                </span>
                <a href="/post/278055#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">1</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">15 февраля 2016 в 14:28</span>
              <a href="/post/277155/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common'); }">Оптимизация UI: Опыт 1cloud</a>

              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span>
                      <span class="post-info__meta-counter">+6</span>
                </span>
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">5,7k</span>
                </span>
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_star"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">27</span>
                </span>
                <a href="/post/277155#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">5</span>
                </a>
              </div>
            </li>
        </ul>

      </div>
    </div>

        



            <div class="comments-section" id="comments">
    <header class="comments-section__head">
      <span class="comments-section__head-title">Комментарии <strong class="comments-section__head-counter" id="comments_count">1</strong></span>
      
    </header>
    
    

    <ul class="content-list content-list_comments" id="comments-list">
        <li class="content-list__item content-list__item_comment js-comment " rel="10404208">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_10404208">
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="10404208">
          <a href="https://habrahabr.ru/users/neochapay/" class="user-info user-info_inline"  data-user-login="neochapay">
    <img src="//habrastorage.org/getpro/habr/avatars/51d/2c1/af4/51d2c1af466caebb8fd3579eca6acd84_small.png" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">neochapay</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">07.09.17 в 11:23</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_10404208" class="icon_comment-anchor" title="Ссылка на комментарий">
      <svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M4 16v-8h-4v-4h4v-4h4v4h8v-4h4v4h4v4h-4v8h4v4h-4v4h-4v-4h-8v4h-4v-4h-4v-4h4zm4 0h8v-8h-8v8z"/></svg>

    </a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#" class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="10404208" data-action="add" title="Только зарегистрированные пользователи могут добавлять публикации в избранное" disabled>
        <svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>

      </a>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_10404208" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="10404208" data-parent_id="0" title="Вернуться к ответу"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M12 24c-6.627 0-12-5.373-12-12s5.373-12 12-12 12 5.373 12 12-5.373 12-12 12zm5.333-7.335l2.666-2.666-8.001-7.999-7.999 7.999 2.666 2.666 5.333-5.333 5.334 5.333z"/></svg>
</a>
  </li>
</ul>

            <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="10404208" data-post-target="336730" data-type="3">
    <button type="button" class="btn voting-wjt__button voting-wjt__button_small" data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><span class="icon-svg_arrow-up icon-svg_arrow-medium "><svg class="icon-svg" width="15" height="24" viewBox="0 0 15 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M4.5 24h6v-15h-6v15zm3-24l-7.5 9h15l-7.5-9z"/></svg>
</span></button>

    <span class="voting-wjt__counter  voting-wjt__counter_negative js-score" title="Общий рейтинг 2: &uarr;0 и &darr;2">–2</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small" data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><span class="icon-svg_arrow-down icon-svg_arrow-medium "><svg class="icon-svg" width="15" height="24" viewBox="0 0 15 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M4.5 24h6v-15h-6v15zm3-24l-7.5 9h15l-7.5-9z"/></svg>
</span></button>
  </div>

        </div>

        <div class="comment__message comment__message_downgrade comment__message_downgrade-2">Новый уровень закладок для АНБ</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_10404208"></ul>
  </li>

      
    </ul>
    <div class="js-form_placeholder">
              <p class="for_users_only_msg">Только <a href="/info/help/registration/">полноправные пользователи</a> могут оставлять комментарии. <a href="https://habrahabr.ru/auth/login/">Войдите</a>, пожалуйста.</p>

    </div>
  </div>


      </div>
    </div>

    <div class="sidebar_right sidebar_content-area">
        
  <div class="default-block default-block_sidebar">
  <div class="default-block__header">
    <span class="default-block__header-title">Информация</span>
  </div>
  <div class="default-block__content default-block__content_profile-summary">
      <ul class="defination-list">
          <li class="defination-list__item defination-list__item_profile-summary">
            <span class="defination-list__label defination-list__label_profile-summary">Дата основания</span>
            <span class="defination-list__value">01 августа 2012</span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <span class="defination-list__label defination-list__label_profile-summary">Локация</span>
            <span class="defination-list__value">
              Санкт-Петербург<br/>Россия
            </span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <span class="defination-list__label defination-list__label_profile-summary">Сайт</span>
            <span class="defination-list__value"><a href="https://1cloud.ru/" target="_blank" class="defination-list__link" title="https://1cloud.ru/">1cloud.ru</a></span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <span class="defination-list__label defination-list__label_profile-summary">Численность</span>
            <span class="defination-list__value">31&#8211;50 человек</span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <span class="defination-list__label defination-list__label_profile-summary">Дата регистрации</span>
            <span class="defination-list__value">22 мая 2014</span>
          </li>
      </ul>
  </div>
</div>

  


      <div class="default-block default-block_sidebar">
  <div class="default-block__header">
    <span class="default-block__header-title">Виджет</span>
  </div>
  <div class="default-block__content default-block__content_centered sidebar-block">
    <div class="sidebar-block__banner">
      <a href="https://1cloud.ru/services/vps-vds/?utm_source=habra&utm_campaign=vds" class="sidebar-block__banner-link">
        <img src="//habrastorage.org/getpro/habr/widget/7e0/c8e/9e7/7e0c8e9e7a5f4ca0abb0e8c6c2f0ae10.png" class="sidebar-block__banner-image" />
        
      </a>
    </div>

    <div class="sidebar-block__paragraph">
      <br>
<h1 style="color:#F9B542;text-align: left "><b>Надежный виртуальный сервер</b> </h1>
<br/>
<p style="color:#5066AB;text-align: left ;font-size: 15px  ">Разверните виртуальный выделенный сервер всего за 2 минуты и также быстро изменяйте его конфигурацию в соответствии с вашими текущими потребностями.</p> 
<p style="color:#5066AB;text-align: left ;font-size: 15px">От <b>317</b> руб. в месяц<p> 
<p style="color:#5066AB;text-align: left ;font-size: 15px">Бесплатное тестирование 3-5 дней!</p>
<a href="https://1cloud.ru/services/vps-vds"><img style="max-width:100%; height:auto;"  src="https://1cloudstat.com/img/habr/%D0%A2%D0%B5%D1%81%D1%82%D0%B8%D1%80%D0%BE%D0%B2%D0%B0%D1%82%D1%8C2.png"/></a>
 <img src="https://vk.com/rtrg?r=SSQvHFht2KpTUojeXl0dLSjG52Wk8zbrt4TVCFIL9ZnbBtPAemJAWeSw8FZ52h9j4PFu6s*SUDpSaxL0ccy8n835R8IASET*0LAf5YMvnHrIPhe8UMEjkBGPdzfv2xv6m/uGNcp4TW8tWXc9PG9QEMCnkBGQNi*CbwRShUxiOhs-&pixel_id=1000001244"/>
    </div>
  </div>
</div>









      <div class="default-block default-block_sidebar">
  <div class="default-block__header">
    <span class="default-block__header-title">Виджет</span>
  </div>
  <div class="default-block__content  sidebar-block">
    <div class="sidebar-block__banner">
      <a href="https://1cloud.ru/services/ssl/?utm_source=habra&utm_campaign=ssl" class="sidebar-block__banner-link">
        <img src="//habrastorage.org/getpro/habr/widget/723/ca6/9a0/723ca69a068b99890c9485b3d05b1d29.png" class="sidebar-block__banner-image" />
        
      </a>
    </div>

    <div class="sidebar-block__paragraph">
      <p style="color:#5066AB;text-align: left ;font-size: 15px  ">Все <b>SSL-сертификаты</b> от доверенных центров сертификации по минимальным ценам!</p>
<p style="color:#5066AB;text-align: left ;font-size: 15px  ">
<ul>
<li style="color:#5066AB;text-align: left ;font-size: 15px  ">Сomodo PositiveSSL :  <b>396 руб</b></li>
<li style="color:#5066AB;text-align: left ;font-size: 15px  ">Wildcard :  <b>6 072 руб</b></li>
<li style="color:#5066AB;text-align: left ;font-size: 15px  ">Multi-Domain  :  <b>1 936 руб</b></li>
</ul> </li>
</p>
<a href="https://1cloud.ru/services/ssl"><img style="max-width:100%; height:auto;" src="https://1cloudstat.com/img/habr/Узнать-больше2.png"/></a>
    </div>
  </div>
</div>









      <div class="default-block default-block_sidebar">
  <div class="default-block__header">
    <span class="default-block__header-title">Виджет</span>
  </div>
  <div class="default-block__content default-block__content_centered sidebar-block">
    <div class="sidebar-block__banner">
      <a href="https://1cloud.ru/services/private-cloud/?utm_source=habra&utm_campaign=private-cloud" class="sidebar-block__banner-link">
        <img src="//habrastorage.org/getpro/habr/widget/ebd/9b6/fbb/ebd9b6fbb93adfa44da43ca269539aeb.png" class="sidebar-block__banner-image" />
        
      </a>
    </div>

    <div class="sidebar-block__paragraph">
      <br/>
<br/>
<h1 style="color:#F9B542;text-align: left"><b>Частное облако 1cloud</b></h1><br/>
<p style="color:#5066AB;text-align: left ;font-size: 15px">Создайте собственный масштабируемый пул вычислительных ресурсов всего в несколько кликов и управляйте им через удобную панель управления или API 1cloud.ru.</p>

<p style="color:#5066AB;text-align: left ;font-size: 15px">Оборудование Cisco, Dell, NetApp</p>
<p style="color:#5066AB;text-align: left ;font-size: 15px">Гибкая система биллинга</p>
<p style="color:#5066AB;text-align: left ;font-size: 15px">Бесплатное тестирование</p>

<a href="https://1cloud.ru/services/private-cloud"><img style="max-width:100%; height:auto;" src="https://1cloudstat.com/img/habr/%D0%A2%D0%B5%D1%81%D1%82%D0%B8%D1%80%D0%BE%D0%B2%D0%B0%D1%82%D1%8C2.png"/></a>
    </div>
  </div>
</div>








        <div class="default-block default-block_sidebar">
    <div class="default-block__header">
      <span class="default-block__header-title">Ссылки</span>
    </div>
    <div class="default-block__content">
      <ul class="content-list content-list_company-links">
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/vps-vds/windows" class="company-links__title">VDS Windows (тестирование бесплатно)</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/vps-vds/linux" class="company-links__title">VDS Linux (тестирование бесплатно)</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/services/private-cloud" class="company-links__title">Частное облако(тестирование бесплатно)</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/Company/Referral" class="company-links__title">Выгодная партнерская программа</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/services/ssl" class="company-links__title">SSL-cсертификаты по самым низким ценам</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/services/dns" class="company-links__title">Бесплатный DNS-хостинг</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/infrastructure/arkhitektura-oblaka-1cloud" class="company-links__title">Архитектура облака 1cloud</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/infrastructure/datacenter-saint-petersburg" class="company-links__title">ЦОД в Санкт-Петербурге</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/infrastructure/datacenter-moskow" class="company-links__title">ЦОД в Москве</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://1cloud.ru/company/sla" class="company-links__title">Наш SLA</a>
            <div class="company-links__link">1cloud.ru</div>
          </li>
      </div>
    </ul>
  </div>















        <div class="default-block default-block_sidebar">
    <div class="default-block__header">
      <span class="default-block__header-title">ВКонтакте</span>
    </div>
    <div class="default-block__content sidebar-block">
      <script type="text/javascript" src="//vk.com/js/api/openapi.js?63"></script>
      <div id="vk_groups"></div>
      <script type="text/javascript">
        VK.Widgets.Group("vk_groups", {mode: 0, width: '260', height: '300'}, 55009336);
      </script>
    </div>
  </div>








      <div class="default-block default-block_sidebar">
  <div class="default-block__header">
    <span class="default-block__header-title">Facebook</span>
  </div>
  <div class="default-block__content sidebar-block">
    <div id="facebook_like_box"></div>
    <script  type="text/javascript">
      (function () {
        $('#facebook_like_box').html('<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2F1cloudru&tabs=timeline&width=260&height=300&small_header=true&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="100%" height="300" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>');
      }());
    </script>
  </div>
</div>








    <div class="js-ad_sticky">
    <div class="default-block">
      <div class="default-block__header">
        <span class="default-block__header-title">Блог на Хабрахабре</span>
      </div>
      <div class="default-block__content">
        <ul class="content-list">
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/336730/" class="post-info__title">Google Titan — стали известны новые подробности о чипе</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">1,2k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/336730/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">1</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/336514/" class="post-info__title">Киму Доткому вернули часть конфискованного имущества</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">7,9k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/336514/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">9</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/335890/" class="post-info__title">«Каждому по кванту»: Станут ли квантовые вычисления коммерческим продуктом?</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">3,9k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/335890/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">7</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/335664/" class="post-info__title">«300 миллионов книг на километр»: IBM продлевает жизнь магнитной ленте</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">4,3k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/335664/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">10</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/335558/" class="post-info__title">Рынок источников бесперебойного питания вырос впервые за четыре года</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">2,7k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/335558/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">0</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/335246/" class="post-info__title">Клиент у руля, или почему провайдеру следует передать штурвал</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">1,6k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/335246/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">2</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/334552/" class="post-info__title">Четверть миллиона за «жука»: Microsoft начинает активную борьбу с багами</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">7,2k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/334552/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">3</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/334278/" class="post-info__title">Немного о SSL-сертификатах: Какой выбрать и как получить</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">7,6k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/334278/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">35</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/333988/" class="post-info__title">Команда веб-энтузиастов представила P2P-браузер Beaker</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">10,2k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/333988/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">12</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <a href="https://habrahabr.ru/company/1cloud/blog/333658/" class="post-info__title">Стоимость хранения данных: «игра с нулевой суммой»</a>
              <div class="post-info__meta">
                <span class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">6k</span>
                </span>

                <a href="https://habrahabr.ru/company/1cloud/blog/333658/#comments" class="post-info__meta-item">
                  <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter post-info__meta-counter_small">9</span>
                </a>
              </div>
            </li>
        </ul>
      </div>
    </div>
  </div>

  

    </div>
  </div>

  

        </div>
      </div>

        <div class="layout__row layout__row_promo-blocks">
          <div class="layout__cell">
              <div class="column-wrapper column-wrapper_bottom column-wrapper_bordered">
    <div class="content_left">
      

  <div class="default-block default-block_content">
    <div class="default-block__header default-block__header_large">
      <span class="default-block__header-title default-block__header-title_large">Самое читаемое</span>
    </div>
    <div class="default-block__content default-block__content_most-read" id="broadcast_tabs_posts">
      <ul class="toggle-menu toggle-menu__most-read">
        <li class="toggle-menu__item"><a href="#broadcast_posts_today" class="toggle-menu__item-link active">Сутки</a></li>
        <li class="toggle-menu__item"><a href="#broadcast_posts_week" class="toggle-menu__item-link">Неделя</a></li>
        <li class="toggle-menu__item"><a href="#broadcast_posts_month" class="toggle-menu__item-link">Месяц</a></li>
      </ul>

        <div class="tabs__content tabs__content_reading" id="broadcast_posts_today">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/337290/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'today'); }">Fedora Linux запрещен к распространению на территории Крыма (и временно поломали DNS)</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;61</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">29,6k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">27</span>
                    </span>
                    <a href="https://habrahabr.ru/post/337290/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">231</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/337260/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'today'); }">Наглядное объяснение чисел с плавающей запятой</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;47</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">15,3k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">191</span>
                    </span>
                    <a href="https://habrahabr.ru/post/337260/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">24</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/337340/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'today'); }">Последний отсчёт — Гугл развлекается</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;60</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">13,7k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">18</span>
                    </span>
                    <a href="https://habrahabr.ru/post/337340/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">11</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/company/itsumma/blog/337346/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'today'); }">Ожидание длиной в 15 лет. Nginx Application Server</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;74</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">11,3k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">85</span>
                    </span>
                    <a href="https://habrahabr.ru/company/itsumma/blog/337346/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">65</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/332130/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'today'); }">Выбираем бесплатный сервер в облаке для тестовых целей, домашних проектов и т.д</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;22</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">10,4k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">142</span>
                    </span>
                    <a href="https://habrahabr.ru/post/332130/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">22</span>
                    </a>
                  </div>
                </li>
            </ul>
        </div>
        <div class="tabs__content tabs__content_reading" id="broadcast_posts_week">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/336966/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'week'); }">Настраиваем интернет шлюз с прозрачным обходом блокировок (а рекламу таки будем блокировать)</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;65</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">42,4k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">464</span>
                    </span>
                    <a href="https://habrahabr.ru/post/336966/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">90</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/337010/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'week'); }">Ideal OS: перезагрузка десктопных операционных систем (часть 1)</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;42</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">34,7k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">90</span>
                    </span>
                    <a href="https://habrahabr.ru/post/337010/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">225</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/company/pvs-studio/blog/337182/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'week'); }">Передаю привет разработчикам компании Yandex</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;105</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">32k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">34</span>
                    </span>
                    <a href="https://habrahabr.ru/company/pvs-studio/blog/337182/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">82</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/337048/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'week'); }">Сударь, ваша команда — не команда</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;80</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">30,8k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">249</span>
                    </span>
                    <a href="https://habrahabr.ru/post/337048/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">242</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/337290/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'week'); }">Fedora Linux запрещен к распространению на территории Крыма (и временно поломали DNS)</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;61</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">29,6k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">27</span>
                    </span>
                    <a href="https://habrahabr.ru/post/337290/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">231</span>
                    </a>
                  </div>
                </li>
            </ul>
        </div>
        <div class="tabs__content tabs__content_reading" id="broadcast_posts_month">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/335634/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'month'); }">Как узнать баланс чужой банковской карты, зная её номер?</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;48</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">140k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">90</span>
                    </span>
                    <a href="https://habrahabr.ru/post/335634/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">91</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/335876/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'month'); }">Путешествие за бугор и обратно: как не надо устраиваться работать за рубежом</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;392</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">130k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">231</span>
                    </span>
                    <a href="https://habrahabr.ru/post/335876/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">1159</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/post/335436/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'month'); }">Автономный способ обхода DPI и эффективный способ обхода блокировок сайтов по IP-адресу</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;212</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">104k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">906</span>
                    </span>
                    <a href="https://habrahabr.ru/post/335436/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">298</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/company/kaspersky/blog/336036/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'month'); }">Шесть мифов о блокчейне и Биткойне, или Почему это не такая уж эффективная технология</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;163</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">94,5k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">300</span>
                    </span>
                    <a href="https://habrahabr.ru/company/kaspersky/blog/336036/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">427</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habrahabr.ru/company/croc/blog/335650/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'month'); }">Что может чат-бот</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;101</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">84,4k</span>
                    </span>
                    <span class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">180</span>
                    </span>
                    <a href="https://habrahabr.ru/company/croc/blog/335650/#comments" class="post-info__meta-item">
                      <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">101</span>
                    </a>
                  </div>
                </li>
            </ul>
        </div>
    </div>
  </div>

      

  <div class="default-block default-block_content">
    <div class="default-block__header default-block__header_large">
      <span class="default-block__header-title default-block__header-title_large">Интересные публикации</span>

      <div class="dropdown dropdown_broadcast">
        <button type="button" class="btn icon-svg_cog dropdown-toggle" data-toggle="dropdown">
          <svg class="icon-svg" width="16" height="16" viewBox="0 0 16 16" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M14.461 8c0-.997.614-1.785 1.539-2.326-.167-.557-.387-1.09-.659-1.592-1.037.271-1.876-.135-2.582-.84-.706-.706-.922-1.545-.65-2.582-.502-.273-1.035-.494-1.592-.66-.542.925-1.519 1.539-2.517 1.539-.997 0-1.975-.614-2.517-1.539-.557.166-1.09.387-1.592.659.271 1.037.055 1.877-.65 2.582-.706.706-1.545 1.112-2.582.841-.272.502-.492 1.035-.659 1.592.925.541 1.539 1.329 1.539 2.326 0 .998-.614 1.975-1.539 2.517.167.557.387 1.09.659 1.593 1.037-.271 1.877-.055 2.582.65.705.706.921 1.545.65 2.582.502.271 1.035.492 1.592.658.542-.925 1.52-1.539 2.517-1.539.998 0 1.975.614 2.517 1.539.557-.167 1.09-.387 1.593-.659-.271-1.037-.056-1.876.65-2.582.706-.706 1.545-1.112 2.582-.841.272-.502.492-1.036.659-1.593-.926-.54-1.54-1.328-1.54-2.325zm-6.461 3.479c-1.921 0-3.479-1.558-3.479-3.479s1.557-3.48 3.479-3.48 3.479 1.558 3.479 3.48-1.557 3.479-3.479 3.479z"/></svg>
        </button>
        <div class="dropdown-container">
          <ul class="n-dropdown-menu n-dropdown-menu_most-read" id="filter">
            <li class="n-dropdown-menu__item">
              <label class="checkbox checkbox_most-read checkbox_custom">
                <input type="checkbox" class="checkbox__input" name="habrahabr" checked/>
                <span class="checkbox__label">Хабрахабр</span>
              </label>
            </li>
            <li class="n-dropdown-menu__item">
              <label class="checkbox checkbox_most-read checkbox_custom">
                <input type="checkbox" class="checkbox__input" name="geektimes" checked/>
                <span class="checkbox__label">Geektimes</span>
              </label>
            </li>
          </ul>
        </div>
      </div>
    </div>

    <div class="default-block__content">
      <ul class="content-list content-list_most-interesting" id="list" data-posts-count="5">
          <li class="content-list__item content-list__item_devided post-info hidden" data-type="habrahabr">
            <div class="post-info__title post-info__title_large" >
              <a href="https://habrahabr.ru/post/337376/" class="post-info__title-link" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'interesting_posts', 'post'); }" data-utm="?utm_source=tm_habrahabr&utm_medium=tm_block&utm_campaign=tm_promo">Конференция ISDEF: развиваем не продукт, а бизнес</a>
            </div>
            <div class="post-info__meta">
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;7</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">41</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">0</span>
              </span>
              <a href="https://habrahabr.ru/post/337376/#comments" class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">1</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info hidden" data-type="habrahabr">
            <div class="post-info__title post-info__title_large" >
              <a href="https://habrahabr.ru/post/337324/" class="post-info__title-link" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'interesting_posts', 'post'); }" data-utm="?utm_source=tm_habrahabr&utm_medium=tm_block&utm_campaign=tm_promo">FullStack 2017 в Лондоне: детали</a>
            </div>
            <div class="post-info__meta">
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;5</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">195</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">1</span>
              </span>
              <a href="https://habrahabr.ru/post/337324/#comments" class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">0</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info hidden" data-type="habrahabr">
            <div class="post-info__title post-info__title_large" >
              <a href="https://habrahabr.ru/post/337368/" class="post-info__title-link" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'interesting_posts', 'post'); }" data-utm="?utm_source=tm_habrahabr&utm_medium=tm_block&utm_campaign=tm_promo">Data Science: Про любовь, имена и не только. Часть II</a>
            </div>
            <div class="post-info__meta">
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;12</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">801</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">4</span>
              </span>
              <a href="https://habrahabr.ru/post/337368/#comments" class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">8</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info hidden" data-type="habrahabr">
            <div class="post-info__title post-info__title_large" >
              <a href="https://habrahabr.ru/post/337264/" class="post-info__title-link" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'interesting_posts', 'post'); }" data-utm="?utm_source=tm_habrahabr&utm_medium=tm_block&utm_campaign=tm_promo">ИИ для покера: как научить алгоритмы блефовать</a>
            </div>
            <div class="post-info__meta">
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;5</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">785</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">6</span>
              </span>
              <a href="https://habrahabr.ru/post/337264/#comments" class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">0</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info hidden" data-type="habrahabr">
            <div class="post-info__title post-info__title_large" >
              <a href="https://habrahabr.ru/post/337300/" class="post-info__title-link" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'interesting_posts', 'post'); }" data-utm="?utm_source=tm_habrahabr&utm_medium=tm_block&utm_campaign=tm_promo">Внутренние механизмы V8 и быстрая работа со свойствами объектов</a>
            </div>
            <div class="post-info__meta">
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_rating"><svg class="icon-svg" width="14" height="16" viewBox="0 0 14 16" aria-hidden="true" version="1.1" role="img"><path d="M13.27 7.486l-6.389-7.39c-.112-.128-.316-.128-.427 0l-6.389 7.39c-.151.175-.022.439.213.439h3.319c.154 0 .277.119.277.268v7.54c0 .149.124.267.278.267h5.03c.154 0 .278-.118.278-.268v-7.538c0-.148.123-.268.277-.268h3.318c.236 0 .364-.265.214-.439z"/></svg></span><span class="post-info__meta-counter">&plus;11</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_views"><svg class="icon-svg" width="42" height="24" viewBox="0 0 42 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M21 0c13.776 0 21 10.357 21 12s-7.224 12-21 12-21-10.357-21-12 7.224-12 21-12zm0 21.232c5.156 0 9.334-4.133 9.334-9.232s-4.179-9.232-9.334-9.232c-5.155 0-9.335 4.133-9.335 9.232s4.179 9.232 9.335 9.232zm0-9.232c-.053 1.096 4.116 2.523 3.3 3.352-1.774 1.803-4.691 1.763-6.513-.088s-1.861-4.813-.087-6.616 4.691-1.763 6.513.088c.984 1-3.15 1.973-3.213 3.264z"/></svg>
</span><span class="post-info__meta-counter">390</span>
              </span>
              <span class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_bookmark-mini"><svg class="icon-svg" width="20" height="32" viewBox="0 0 20 32" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M10 25.645l10 6.355v-30c0-1.105-.895-2-2-2h-16c-1.105 0-2 .895-2 2v30l10-6.355z"/></svg>
</span><span class="post-info__meta-counter">15</span>
              </span>
              <a href="https://habrahabr.ru/post/337300/#comments" class="post-info__meta-item">
                <span class="post-info__meta-icon icon-svg_comments"><svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" aria-labelledby="title" version="1.1" role="img"><path d="M1.5 0h21c.828 0 1.5.672 1.5 1.5v15c0 .828-.672 1.5-1.5 1.5h-21c-.828 0-1.5-.672-1.5-1.5v-15c0-.828.672-1.5 1.5-1.5zm12 18v6l-7.5-6h7.5z"/></svg>
</span><span class="post-info__meta-counter">4</span>
              </a>
            </div>
          </li>
      </ul>
    </div>
  </div>

    </div>

    <div class="sidebar_right">
    </div>
  </div>

          </div>
        </div>

      <div class="layout__row layout__row_footer-links">
        <div class="layout__cell">
          <div class="footer-grid footer-grid_menu">
  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">
      Аккаунт
    </h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
          <li class="footer-menu__item">
            <a href="https://habrahabr.ru/auth/login/" class="footer-menu__item-link">Войти</a>
          </li>
          <li class="footer-menu__item">
            <a href="https://habrahabr.ru/auth/register/" class="footer-menu__item-link">Регистрация</a>
          </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Разделы</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://habrahabr.ru/posts/top/" class="footer-menu__item-link">Публикации</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habrahabr.ru/hubs/" class="footer-menu__item-link">Хабы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habrahabr.ru/companies/" class="footer-menu__item-link">Компании</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habrahabr.ru/users/" class="footer-menu__item-link">Пользователи</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habrahabr.ru/sandbox/" class="footer-menu__item-link">Песочница</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Информация</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="/info/about/" class="footer-menu__item-link">О сайте</a>
        </li>
        <li class="footer-menu__item">
          <a href="/info/help/rules/" class="footer-menu__item-link">Правила</a>
        </li>
        <li class="footer-menu__item">
          <a href="/info/help/" class="footer-menu__item-link">Помощь</a>
        </li>
        <li class="footer-menu__item">
          <a href="/info/agreement/" class="footer-menu__item-link">Соглашение</a>
        </li>
        <li class="footer-menu__item">
          <a href="/info/confidential/" class="footer-menu__item-link">Конфиденциальность</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Услуги</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/advertising/" target="_blank" class="footer-menu__item-link">Реклама</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/corpblog/" target="_blank" class="footer-menu__item-link">Тарифы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/content/" target="_blank" class="footer-menu__item-link">Контент</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/workshops/" target="_blank" class="footer-menu__item-link">Семинары</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-grid__item_300 footer-block">
    <h3 class="footer-block__title">Приложения</h3>
    <div class="footer-block__content footer-block__content_apps">
      <a href="https://appmetrica.yandex.com/serve/240693928167260216?utm_source=HH_desktop&utm_medium=button&utm_campaign=appiOS" class="footer-menu__app" target="_blank" onclick="if (  typeof ga === 'function') { ga('send', 'event', 'footer', 'links', 'ios_app'); }"><svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="140" height="40" viewBox="0 0 140 40"><path fill="#fff" d="M0 0h140v40h-140z"/><path d="M139.387 35.99c0 2.215-1.794 4.01-4.014 4.01h-131.354c-2.218 0-4.019-1.794-4.019-4.01v-31.975c0-2.214 1.801-4.015 4.019-4.015h131.353c2.22 0 4.014 1.801 4.014 4.015l.001 31.975z"/><path fill="#fff" d="M30.609 19.78c-.03-3.374 2.763-5.016 2.89-5.092-1.582-2.306-4.034-2.621-4.895-2.647-2.059-.217-4.057 1.232-5.106 1.232-1.07 0-2.685-1.211-4.426-1.176-2.24.035-4.336 1.332-5.486 3.346-2.372 4.107-.603 10.142 1.67 13.462 1.137 1.626 2.465 3.441 4.204 3.377 1.701-.07 2.337-1.085 4.39-1.085 2.034 0 2.631 1.085 4.404 1.044 1.826-.029 2.975-1.633 4.072-3.274 1.314-1.863 1.841-3.699 1.862-3.793-.041-.013-3.544-1.35-3.579-5.394zM27.259 9.858c.915-1.144 1.541-2.701 1.367-4.281-1.324.059-2.981.916-3.934 2.035-.844.986-1.598 2.603-1.403 4.123 1.488.111 3.015-.751 3.97-1.877zM55.229 32.05h-2.378l-1.302-4.092h-4.527l-1.241 4.092h-2.315l4.485-13.932h2.77l4.508 13.932zm-4.072-5.809l-1.178-3.638c-.125-.372-.358-1.247-.702-2.625h-.042c-.137.593-.358 1.468-.662 2.625l-1.157 3.638h3.741zM66.763 26.903c0 1.709-.462 3.059-1.385 4.05-.827.883-1.854 1.323-3.08 1.323-1.323 0-2.274-.475-2.853-1.426h-.042v5.292h-2.232v-10.831c0-1.074-.028-2.177-.083-3.307h1.963l.125 1.592h.042c.744-1.2 1.874-1.799 3.39-1.799 1.185 0 2.174.468 2.966 1.405.793.938 1.189 2.172 1.189 3.701zm-2.274.082c0-.978-.22-1.784-.662-2.418-.483-.662-1.131-.992-1.943-.992-.551 0-1.051.184-1.498.548-.448.366-.741.845-.878 1.437-.069.276-.104.503-.104.68v1.675c0 .731.224 1.347.672 1.851s1.03.755 1.746.755c.841 0 1.495-.325 1.963-.972.47-.648.704-1.503.704-2.564zM78.318 26.903c0 1.709-.462 3.059-1.386 4.05-.826.883-1.853 1.323-3.079 1.323-1.323 0-2.274-.475-2.852-1.426h-.042v5.292h-2.232v-10.831c0-1.074-.028-2.177-.083-3.307h1.963l.125 1.592h.042c.743-1.2 1.873-1.799 3.39-1.799 1.184 0 2.173.468 2.967 1.405.79.938 1.187 2.172 1.187 3.701zm-2.274.082c0-.978-.221-1.784-.663-2.418-.483-.662-1.129-.992-1.942-.992-.552 0-1.051.184-1.499.548-.448.366-.74.845-.877 1.437-.068.276-.104.503-.104.68v1.675c0 .731.224 1.347.67 1.851.448.503 1.03.755 1.748.755.841 0 1.495-.325 1.963-.972.469-.648.704-1.503.704-2.564zM91.236 28.143c0 1.185-.411 2.149-1.237 2.894-.908.813-2.171 1.22-3.795 1.22-1.499 0-2.701-.289-3.611-.868l.517-1.86c.98.593 2.055.89 3.227.89.841 0 1.495-.191 1.965-.57.468-.379.701-.888.701-1.522 0-.565-.193-1.042-.579-1.428-.384-.386-1.026-.745-1.922-1.077-2.439-.91-3.658-2.242-3.658-3.995 0-1.145.427-2.084 1.282-2.815.852-.732 1.989-1.097 3.411-1.097 1.268 0 2.321.221 3.162.662l-.558 1.82c-.785-.427-1.673-.641-2.666-.641-.785 0-1.399.194-1.838.579-.372.344-.558.764-.558 1.262 0 .551.213 1.006.64 1.364.372.331 1.047.689 2.027 1.075 1.199.483 2.079 1.047 2.646 1.694.563.642.844 1.45.844 2.413zM98.616 23.679h-2.46v4.878c0 1.241.433 1.86 1.302 1.86.399 0 .73-.035.991-.104l.062 1.695c-.44.164-1.019.247-1.736.247-.881 0-1.57-.269-2.068-.806-.495-.538-.744-1.441-.744-2.708v-5.064h-1.466v-1.675h1.466v-1.839l2.192-.662v2.501h2.46l.001 1.677zM109.716 26.944c0 1.544-.442 2.812-1.323 3.803-.924 1.021-2.151 1.53-3.681 1.53-1.474 0-2.648-.489-3.523-1.467s-1.313-2.212-1.313-3.7c0-1.557.45-2.832 1.354-3.823.901-.992 2.118-1.489 3.647-1.489 1.474 0 2.66.489 3.555 1.468.857.95 1.284 2.176 1.284 3.678zm-2.315.072c0-.927-.198-1.721-.599-2.384-.468-.802-1.137-1.202-2.004-1.202-.897 0-1.579.401-2.047 1.202-.401.664-.599 1.471-.599 2.426 0 .927.198 1.721.599 2.383.483.802 1.157 1.202 2.027 1.202.852 0 1.521-.408 2.004-1.223.411-.675.619-1.478.619-2.404zM116.971 23.967c-.221-.041-.456-.062-.704-.062-.785 0-1.392.296-1.82.89-.372.523-.558 1.185-.558 1.984v5.271h-2.231l.021-6.882c0-1.158-.028-2.212-.084-3.163h1.944l.082 1.922h.062c.236-.661.607-1.192 1.116-1.591.497-.359 1.034-.538 1.613-.538.206 0 .393.015.558.041l.001 2.128zM126.954 26.552c0 .4-.026.737-.082 1.012h-6.696c.026.992.35 1.751.972 2.275.564.468 1.294.702 2.19.702.991 0 1.896-.158 2.709-.475l.35 1.549c-.951.415-2.073.621-3.368.621-1.558 0-2.781-.459-3.67-1.375s-1.333-2.146-1.333-3.689c0-1.515.414-2.776 1.242-3.782.867-1.074 2.038-1.611 3.512-1.611 1.448 0 2.544.537 3.288 1.611.589.853.886 1.908.886 3.162zm-2.129-.579c.015-.662-.131-1.233-.433-1.716-.386-.621-.98-.931-1.779-.931-.73 0-1.323.303-1.777.91-.372.483-.593 1.062-.661 1.736l4.649.001zM44.529 6.682c.238-.142.506-.262.807-.36s.654-.148 1.062-.148c.656 0 1.174.156 1.553.467s.568.731.568 1.259c0 .42-.127.772-.38 1.056s-.578.474-.97.568v.03c.217.035.422.093.615.178s.363.198.508.34c.146.142.261.308.345.498.084.189.127.399.127.63 0 .379-.076.697-.229.955s-.352.467-.599.63c-.246.162-.522.28-.827.35s-.609.107-.914.107c-.326 0-.647-.035-.965-.102s-.612-.179-.884-.335l.274-.843c.176.088.403.173.68.254.277.082.558.121.843.121.467 0 .828-.105 1.081-.314.253-.21.381-.491.381-.843 0-.238-.051-.431-.153-.584-.103-.153-.235-.272-.397-.361-.162-.088-.343-.149-.543-.182s-.398-.051-.594-.051h-.457v-.831h.457c.209 0 .404-.026.584-.082.179-.053.335-.13.467-.228s.236-.216.31-.351c.073-.135.111-.288.111-.457 0-.305-.109-.543-.326-.716s-.508-.26-.873-.26c-.25 0-.501.041-.752.121-.25.082-.474.17-.671.264l-.239-.78zM53.251 13.131l-.081-.568h-.03c-.331.453-.811.68-1.442.68-.224 0-.426-.038-.609-.112s-.342-.176-.477-.305c-.136-.129-.24-.281-.315-.457-.074-.176-.111-.37-.111-.579 0-.616.25-1.078.752-1.386s1.211-.462 2.133-.462v-.091c0-.65-.341-.975-1.024-.975-.487 0-.916.122-1.287.365l-.223-.72c.453-.284 1.018-.426 1.693-.426 1.291 0 1.937.68 1.937 2.041v1.817c0 .508.024.9.071 1.178h-.986zm-.152-2.457c-.612 0-1.069.077-1.368.233s-.449.41-.449.762c0 .258.07.45.211.579s.32.193.536.193c.141 0 .275-.025.404-.076.128-.05.24-.12.337-.208.098-.088.177-.195.239-.32.061-.126.09-.259.09-.401v-.762zM59.457 8.196v.904h-2.052v4.032h-1.096v-4.936h3.148zM65.732 10.603c0 .393-.054.752-.162 1.076-.109.326-.259.603-.452.832-.193.23-.423.41-.69.538-.268.129-.563.194-.889.194-.65 0-1.117-.233-1.402-.7h-.021v2.599h-1.097v-5.321l-.01-.798-.029-.828h.964l.062.782h.021c.365-.588.92-.884 1.666-.884.29 0 .56.061.807.182.247.122.462.293.645.513s.327.484.431.793c.103.309.156.649.156 1.022zm-1.116.041c0-.244-.029-.469-.087-.675s-.142-.382-.253-.528-.247-.261-.406-.345c-.159-.085-.337-.127-.534-.127-.155 0-.308.035-.457.102-.15.067-.28.159-.39.274-.112.115-.201.254-.269.417s-.103.335-.103.518v.823c0 .182.028.352.087.508s.138.291.243.406.23.205.376.269c.146.065.306.096.482.096.414 0 .735-.157.965-.472.229-.316.346-.739.346-1.266zM71.624 8.196l-1.25 3.422c-.297.812-.587 1.477-.868 1.995s-.55.895-.807 1.133c-.379.338-.782.545-1.209.619l-.264-.923c.284-.074.555-.22.812-.437s.463-.487.62-.812l.081-.223-.061-.233-1.788-4.54h1.208l.935 2.752.142.437.153.538h.021l.111-.411.162-.574.833-2.742 1.168-.001zM73.523 10.247h.507c.372 0 .661-.067.863-.203s.305-.302.305-.498c0-.203-.086-.365-.26-.487-.172-.121-.411-.183-.716-.183-.197 0-.395.032-.593.096-.2.065-.384.144-.554.239l-.284-.71c.284-.155.566-.262.849-.319.281-.058.562-.087.847-.087.225 0 .45.022.676.066.225.044.427.118.603.223s.321.242.431.411c.112.17.168.379.168.63 0 .156-.03.293-.092.411-.06.118-.141.223-.243.314s-.215.166-.339.223c-.125.058-.253.101-.38.128v.03c.161.021.319.062.472.122.152.061.288.14.411.239.12.098.219.217.294.355.073.139.11.296.11.472 0 .291-.069.535-.213.731-.141.197-.323.352-.544.467-.219.115-.462.198-.726.249s-.521.076-.771.076c-.305 0-.607-.032-.903-.096-.298-.065-.566-.164-.804-.299l.286-.721c.176.095.376.175.603.239s.459.096.695.096c.372 0 .659-.072.858-.218.198-.146.298-.327.298-.543 0-.142-.032-.262-.101-.36-.068-.098-.163-.178-.284-.239-.122-.061-.264-.104-.427-.127-.161-.024-.339-.036-.528-.036h-.517v-.691zM79.381 8.196v1.746c0 .4-.006.759-.021 1.076l-.051 1.005.021.02.38-.757.382-.757 1.219-2.336h1.421v4.935h-1.036v-1.746c0-.365.01-.731.026-1.096l.055-1.108h-.051c-.114.305-.229.568-.345.793l-.343.691-.626 1.219c-.206.406-.425.823-.654 1.249h-1.421v-4.934h1.044zM88.521 8.196v.904h-1.502v4.032h-1.079v-4.032h-1.493v-.904h4.074zM94.115 10.43l-.01.269-.03.228h-3.29c.015.467.161.828.442 1.081s.652.381 1.112.381c.481 0 .924-.077 1.331-.233l.172.762c-.468.203-1.019.305-1.656.305-.384 0-.73-.06-1.034-.178-.305-.118-.562-.286-.773-.503-.208-.217-.371-.477-.483-.782-.11-.305-.165-.646-.165-1.025s.055-.73.165-1.051c.112-.321.27-.601.472-.838.204-.238.45-.423.736-.559.288-.135.609-.203.961-.203.311 0 .593.055.849.168.253.111.47.27.648.477.18.206.317.454.411.741s.142.609.142.96zm-1.047-.283c0-.386-.092-.699-.278-.939s-.455-.361-.807-.361c-.319 0-.588.121-.811.365s-.352.555-.386.935h2.282zM98.534 8.237c.197-.033.446-.061.751-.082s.616-.03.935-.03c.202 0 .431.013.685.036s.497.077.726.162c.231.085.423.211.579.381s.236.399.236.69c0 .15-.028.284-.082.401-.055.118-.127.222-.219.31s-.197.161-.315.218c-.118.058-.241.101-.371.127l.01.03c.358.061.65.189.873.386s.335.467.335.812c0 .345-.096.62-.284.823-.191.203-.423.356-.701.457s-.571.166-.879.194c-.307.026-.583.041-.826.041-.272 0-.538-.006-.798-.021l-.654-.041v-4.894zm1.056 1.97h.558c.17 0 .331-.012.483-.036.153-.023.286-.061.401-.111.116-.051.204-.118.27-.203.064-.085.096-.187.096-.31 0-.223-.092-.387-.281-.492-.186-.105-.478-.157-.877-.157l-.3.01-.35.03v1.269zm0 2.183l.339.03.321.01c.15 0 .3-.009.456-.03.155-.02.298-.059.427-.116s.231-.134.309-.232c.077-.097.118-.227.118-.388 0-.283-.127-.477-.376-.585-.251-.108-.588-.161-1.017-.161h-.577v1.472z"/></svg></a>

      <a href="https://appmetrica.yandex.com/serve/745097116363323173?id=ru.habrahabr&utm_source=HH_desktop&utm_medium=button&utm_campaign=appAndroid" class="footer-menu__app" target="_blank" onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'links', 'android_app'); }"><svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="135" height="40" viewBox="0 0 135 40"><path d="M130 40h-125c-2.75 0-5-2.25-5-5v-30c0-2.75 2.25-5 5-5h125c2.75 0 5 2.25 5 5v30c0 2.75-2.25 5-5 5z"/><path fill="#fff" d="M68.136 21.752c-2.352 0-4.269 1.788-4.269 4.253 0 2.449 1.917 4.253 4.269 4.253 2.352 0 4.269-1.804 4.269-4.253 0-2.465-1.917-4.253-4.269-4.253zm0 6.83c-1.289 0-2.401-1.063-2.401-2.578 0-1.531 1.112-2.578 2.401-2.578 1.289 0 2.4 1.047 2.4 2.578 0 1.515-1.111 2.578-2.4 2.578zm-9.314-6.83c-2.352 0-4.269 1.788-4.269 4.253 0 2.449 1.917 4.253 4.269 4.253 2.352 0 4.269-1.804 4.269-4.253.001-2.465-1.916-4.253-4.269-4.253zm0 6.83c-1.289 0-2.4-1.063-2.4-2.578 0-1.531 1.112-2.578 2.4-2.578 1.289 0 2.4 1.047 2.4 2.578.001 1.515-1.111 2.578-2.4 2.578zm-11.078-5.525v1.804h4.318c-.129 1.015-.467 1.756-.983 2.272-.628.628-1.611 1.321-3.335 1.321-2.658 0-4.736-2.143-4.736-4.801s2.078-4.801 4.736-4.801c1.434 0 2.481.564 3.254 1.289l1.273-1.273c-1.079-1.031-2.513-1.82-4.527-1.82-3.641 0-6.702 2.964-6.702 6.605 0 3.641 3.061 6.605 6.702 6.605 1.966 0 3.448-.644 4.608-1.853 1.192-1.192 1.563-2.868 1.563-4.221 0-.419-.032-.806-.097-1.128h-6.074zm45.308 1.401c-.354-.95-1.434-2.706-3.641-2.706-2.191 0-4.011 1.724-4.011 4.253 0 2.384 1.804 4.253 4.221 4.253 1.949 0 3.077-1.192 3.544-1.885l-1.45-.967c-.483.709-1.144 1.176-2.094 1.176-.951 0-1.627-.435-2.062-1.289l5.687-2.352-.194-.483zm-5.8 1.418c-.048-1.643 1.273-2.481 2.223-2.481.741 0 1.369.371 1.579.902l-3.802 1.579zm-4.623 4.124h1.869v-12.501h-1.869v12.501zm-3.062-7.298h-.064c-.419-.499-1.224-.951-2.239-.951-2.127 0-4.076 1.869-4.076 4.269 0 2.384 1.949 4.237 4.076 4.237 1.015 0 1.82-.451 2.239-.967h.064v.612c0 1.627-.87 2.497-2.272 2.497-1.144 0-1.853-.822-2.143-1.514l-1.627.677c.467 1.128 1.708 2.513 3.77 2.513 2.191 0 4.044-1.289 4.044-4.43v-7.636h-1.772v.693zm-2.142 5.88c-1.289 0-2.368-1.079-2.368-2.562 0-1.498 1.079-2.594 2.368-2.594 1.273 0 2.272 1.096 2.272 2.594-.001 1.483-.999 2.562-2.272 2.562zm24.381-11.083h-4.471v12.501h1.865v-4.736h2.606c2.068 0 4.101-1.497 4.101-3.882s-2.033-3.883-4.101-3.883zm.048 6.025h-2.654v-4.285h2.654c1.395 0 2.187 1.155 2.187 2.143 0 .968-.792 2.142-2.187 2.142zm11.532-1.795c-1.351 0-2.75.595-3.329 1.914l1.657.692c.354-.692 1.013-.917 1.705-.917.965 0 1.946.579 1.962 1.608v.129c-.338-.193-1.062-.483-1.946-.483-1.785 0-3.603.981-3.603 2.815 0 1.673 1.464 2.75 3.104 2.75 1.255 0 1.946-.563 2.38-1.222h.064v.965h1.801v-4.793c0-2.22-1.656-3.458-3.795-3.458zm-.225 6.851c-.611 0-1.464-.306-1.464-1.062 0-.965 1.062-1.335 1.978-1.335.82 0 1.206.177 1.705.418-.145 1.159-1.142 1.979-2.219 1.979zm10.582-6.578l-2.139 5.42h-.064l-2.219-5.42h-2.01l3.329 7.575-1.898 4.214h1.946l5.131-11.789h-2.076zm-16.807 7.998h1.866v-12.501h-1.866v12.501z"/><linearGradient id="a" gradientUnits="userSpaceOnUse" x1="21.8" y1="33.29" x2="5.017" y2="16.508" gradientTransform="matrix(1 0 0 -1 0 42)"><stop offset="0" stop-color="#00A0FF"/><stop offset=".007" stop-color="#00A1FF"/><stop offset=".26" stop-color="#00BEFF"/><stop offset=".512" stop-color="#00D2FF"/><stop offset=".76" stop-color="#00DFFF"/><stop offset="1" stop-color="#00E3FF"/></linearGradient><path fill="url(#a)" d="M10.435 7.538c-.291.308-.463.786-.463 1.405v22.116c0 .62.172 1.097.463 1.405l.074.072 12.389-12.389v-.292l-12.389-12.39-.074.073z"/><linearGradient id="b" gradientUnits="userSpaceOnUse" x1="33.834" y1="21.999" x2="9.637" y2="21.999" gradientTransform="matrix(1 0 0 -1 0 42)"><stop offset="0" stop-color="#FFE000"/><stop offset=".409" stop-color="#FFBD00"/><stop offset=".775" stop-color="#FFA500"/><stop offset="1" stop-color="#FF9C00"/></linearGradient><path fill="url(#b)" d="M27.028 24.278l-4.129-4.131v-.292l4.13-4.13.093.053 4.893 2.78c1.398.794 1.398 2.093 0 2.888l-4.893 2.78-.094.052z"/><linearGradient id="c" gradientUnits="userSpaceOnUse" x1="24.827" y1="19.704" x2="2.069" y2="-3.054" gradientTransform="matrix(1 0 0 -1 0 42)"><stop offset="0" stop-color="#FF3A44"/><stop offset="1" stop-color="#C31162"/></linearGradient><path fill="url(#c)" d="M27.122 24.225l-4.224-4.224-12.463 12.463c.461.488 1.221.548 2.078.061l14.609-8.3"/><linearGradient id="d" gradientUnits="userSpaceOnUse" x1="7.297" y1="41.824" x2="17.46" y2="31.661" gradientTransform="matrix(1 0 0 -1 0 42)"><stop offset="0" stop-color="#32A071"/><stop offset=".069" stop-color="#2DA771"/><stop offset=".476" stop-color="#15CF74"/><stop offset=".801" stop-color="#06E775"/><stop offset="1" stop-color="#00F076"/></linearGradient><path fill="url(#d)" d="M27.122 15.777l-14.608-8.3c-.857-.487-1.617-.426-2.078.061l12.463 12.463 4.223-4.224z"/><path opacity=".2" enable-background="new" d="M27.029 24.132l-14.515 8.247c-.812.461-1.538.431-2.004.011l-.075.075.074.072c.466.42 1.192.451 2.004-.011l14.608-8.3-.092-.094z"/><path opacity=".12" enable-background="new" d="M10.435 32.318c-.291-.308-.463-.786-.463-1.405v.146c0 .619.172 1.097.463 1.405l.075-.075-.075-.071zM32.015 21.299l-4.986 2.833.093.093 4.893-2.78c.699-.397 1.048-.92 1.048-1.443-.059.473-.415.937-1.048 1.297z"/><path opacity=".25" fill="#fff" enable-background="new" d="M12.514 7.623l19.501 11.08c.634.36.989.824 1.048 1.298 0-.523-.349-1.047-1.048-1.444l-19.501-11.08c-1.398-.794-2.541-.135-2.541 1.466v.147c0-1.601 1.143-2.261 2.541-1.467z"/><g fill="#fff" stroke="#fff" stroke-width=".2" stroke-miterlimit="10"><path d="M42.114 14.273h-.737v-2.011h.587c.519-.447.773-1.212.763-2.296v-2.966h4.006v5.263h.67v2.011h-.737v-1.274h-4.551v1.273zm1.383-4.306c.012.949-.179 1.715-.569 2.296h3.033v-4.526h-2.464v2.23zM53.415 12.225c-.59.607-1.323.909-2.2.909-.877 0-1.61-.303-2.199-.909-.59-.606-.884-1.348-.884-2.225s.294-1.619.884-2.225c.589-.607 1.322-.91 2.199-.91.872 0 1.604.305 2.196.914.592.609.888 1.349.888 2.221-.001.877-.296 1.619-.884 2.225zm-3.831-.503c.444.45.987.674 1.63.674.642 0 1.187-.225 1.63-.674.444-.45.667-1.024.667-1.722s-.223-1.273-.667-1.722c-.443-.45-.987-.674-1.63-.674-.643 0-1.186.225-1.63.674-.443.45-.666 1.024-.666 1.722s.223 1.273.666 1.722zM58.179 13.134c-.883 0-1.623-.299-2.221-.896-.598-.598-.896-1.344-.896-2.238s.298-1.64.896-2.237c.598-.598 1.338-.897 2.221-.897.904 0 1.64.327 2.204.981l-.537.52c-.407-.509-.964-.763-1.667-.763-.654 0-1.206.221-1.655.662-.45.441-.675 1.02-.675 1.734s.225 1.293.675 1.734c.449.441 1.001.662 1.655.662.721 0 1.335-.29 1.844-.871l.536.536c-.274.33-.617.591-1.031.783-.413.194-.863.29-1.349.29zM63.677 13h-.771v-5.263h-1.676v-.737h4.123v.737h-1.676v5.263zM70.646 7l-2.271 5.061c-.313.715-.779 1.072-1.399 1.072-.185 0-.383-.044-.596-.134l.201-.712c.129.073.263.109.402.109.179 0 .317-.035.415-.104.098-.07.188-.197.272-.381l.218-.478-2.017-4.433h.905l1.483 3.444h.033l1.449-3.444h.905zM71.52 13v-6h4.341v6h-.771v-5.263h-2.8v5.263h-.77zM77.234 13v-6h.771v2.572h3v-2.572h.771v6h-.771v-2.707h-3v2.707h-.771zM88.058 12.225c-.59.607-1.323.909-2.2.909-.877 0-1.61-.303-2.199-.909-.59-.606-.884-1.348-.884-2.225s.294-1.619.884-2.225c.589-.607 1.322-.91 2.199-.91.872 0 1.604.305 2.196.914.592.609.888 1.349.888 2.221-.001.877-.296 1.619-.884 2.225zm-3.83-.503c.444.45.987.674 1.63.674s1.187-.225 1.63-.674c.444-.45.667-1.024.667-1.722s-.223-1.273-.667-1.722c-.443-.45-.987-.674-1.63-.674s-1.186.225-1.63.674c-.443.45-.666 1.024-.666 1.722s.222 1.273.666 1.722zM92.094 13v-6h2.17c.47 0 .876.155 1.22.465.344.311.516.7.516 1.169 0 .285-.074.537-.223.754-.147.218-.345.383-.591.495v.033c.296.101.539.274.729.519.189.246.285.531.285.855 0 .492-.181.899-.541 1.223-.36.325-.786.487-1.278.487h-2.287zm.77-3.428h1.399c.291 0 .524-.096.7-.289.176-.192.264-.403.264-.632s-.085-.439-.256-.628c-.17-.19-.395-.285-.674-.285h-1.434v1.834zm0 2.691h1.551c.296 0 .536-.104.721-.311.185-.206.276-.433.276-.679 0-.246-.095-.47-.285-.674-.189-.204-.438-.306-.746-.306h-1.517v1.97z"/></g></svg></a>
    </div>
  </div>
</div>

        </div>
      </div>

      <div class="layout__row layout__row_footer">
        <div class="layout__cell">
          <div class="footer-grid footer">
  <div class="footer-grid__item footer-grid__item_380">
    <svg class="icon-svg icon-svg_tmtm" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="32" height="32" viewBox="0 0 32 32"><path fill="#b12b51" d="M0 0v32h23.637l4.175-4.189-4.175 4.175v-8.358h8.358l-4.184 4.184 4.189-4.184v-23.628h-32zm14.653 14.148h-2.088v5.127h-2.106v-5.127h-2.089v-1.423h6.282v1.423zm8.977 1.852v3.275h-2.048v-4.065l-1.487 2.683h-.922l-1.487-2.683v4.065h-1.989v-6.55h2.28l1.686 2.975 1.686-2.975h2.281v3.275z"/><path fill="#fff" d="M8.37 14.148h2.088v5.127h2.106v-5.127h2.089v-1.423h-6.283zM22.264 12.725h-.915l-1.686 2.975-1.686-2.975h-2.28v6.55h1.989v-4.065l1.487 2.683h.922l1.487-2.683v4.065h2.048v-6.55h-.649z"/><path fill="#dc82a0" d="M23.637 23.628v8.358l8.358-8.358z"/></svg>
    <span class="footer__copyright">&copy; 2006 &ndash; 2017 «<a href="https://tmtm.ru/" class="footer__link">TM</a>»</span>
  </div>
  <div class="footer-grid__item">
    <a href="https://habrahabr.ru/feedback/" class="footer__link">Служба поддержки</a>
  </div>
  <div class="footer-grid__item">
      <a href="https://m.habrahabr.ru/post/336730/?mobile=yes" class="footer__link">Мобильная версия</a>
  </div>

  <div class="footer-grid__item footer-grid__item_300">
    <ul class="social-icons">
      <li class="social-icons__item">
        <a href="https://twitter.com/habrahabr"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_twitter"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'twitter'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.414 8.642c-.398.177-.826.296-1.276.35.459-.275.811-.71.977-1.229-.43.254-.905.439-1.41.539-.405-.432-.982-.702-1.621-.702-1.227 0-2.222.994-2.222 2.222 0 .174.019.344.058.506-1.846-.093-3.484-.978-4.579-2.322-.191.328-.301.71-.301 1.117 0 .77.392 1.45.988 1.849-.363-.011-.706-.111-1.006-.278v.028c0 1.077.766 1.974 1.782 2.178-.187.051-.383.078-.586.078-.143 0-.282-.014-.418-.04.282.882 1.103 1.525 2.075 1.542-.76.596-1.718.951-2.759.951-.179 0-.356-.01-.53-.031.983.63 2.15.998 3.406.998 4.086 0 6.321-3.386 6.321-6.321l-.006-.287c.433-.314.81-.705 1.107-1.15z"/></svg>
        </a>
      </li>
      <li class="social-icons__item">
        <a href="https://www.facebook.com/habrahabr.ru"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_facebook"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'facebook'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M14.889 8.608h-1.65c-.195 0-.413.257-.413.6v1.192h2.063v1.698h-2.063v5.102h-1.948v-5.102h-1.766v-1.698h1.766v-1c0-1.434.995-2.6 2.361-2.6h1.65v1.808z"/></svg>
        </a>
      </li>
      <li class="social-icons__item">
        <a href="https://vk.com/habr"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_vkontakte"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'vkontakte'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M16.066 11.93s1.62-2.286 1.782-3.037c.054-.268-.064-.418-.343-.418h-1.406c-.322 0-.44.139-.537.343 0 0-.76 1.619-1.685 2.64-.297.33-.448.429-.612.429-.132 0-.193-.11-.193-.408v-2.607c0-.365-.043-.472-.343-.472h-2.254c-.172 0-.279.1-.279.236 0 .343.526.421.526 1.352v1.921c0 .386-.022.537-.204.537-.483 0-1.631-1.663-2.274-3.552-.129-.386-.268-.494-.633-.494h-1.406c-.204 0-.354.139-.354.343 0 .375.44 2.114 2.167 4.442 1.159 1.566 2.683 2.414 4.056 2.414.838 0 1.041-.139 1.041-.494v-1.202c0-.301.118-.429.29-.429.193 0 .534.062 1.33.848.945.901 1.01 1.276 1.525 1.276h1.578c.161 0 .311-.075.311-.343 0-.354-.462-.987-1.17-1.738-.29-.386-.762-.805-.912-.998-.215-.226-.151-.354-.001-.59z"/></svg>
        </a>
      </li>
      <li class="social-icons__item">
        <a href="https://telegram.me/habr_ru"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_telegram"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'telegram'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.17 7.621l-10.498 3.699c-.169.059-.206.205-.006.286l2.257.904 1.338.536 6.531-4.796s.189.057.125.126l-4.68 5.062-.27.299.356.192 2.962 1.594c.173.093.397.016.447-.199.058-.254 1.691-7.29 1.728-7.447.047-.204-.087-.328-.291-.256zm-6.922 8.637c0 .147.082.188.197.084l1.694-1.522-1.891-.978v2.416z"/></svg>
        </a>
      </li>
      <li class="social-icons__item">
        <a href="https://www.youtube.com/channel/UCd_sTwKqVrweTt4oAKY5y4w"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_youtube"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'youtube'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="32" height="32" viewBox="0 0 32 32"><path d="M3.2 0h25.6c1.767 0 3.2 1.433 3.2 3.2v25.6c0 1.767-1.433 3.2-3.2 3.2h-25.6c-1.767 0-3.2-1.433-3.2-3.2v-25.6c0-1.767 1.433-3.2 3.2-3.2zm18.133 16l-10.667-5.333v10.667l10.667-5.333z"/></svg>

        </a>
      </li>
    </ul>
  </div>
</div>

        </div>
      </div>

      <a href="#" class="layout__elevator hidden" id="scroll_to_top" title="Наверх"  onclick="if (typeof ga === 'function') { ga('send', 'event', 'navigation_button', 'down'); }">
        <svg class="icon-svg icon-svg_scroll-up" width="32" height="32" viewBox="0 0 32 32" aria-hidden="true" version="1.1" role="img"><path d="M16 0C7.164 0 0 7.164 0 16s7.164 16 16 16 16-7.164 16-16S24.836 0 16 0zm8.412 19.523c-.517.512-1.355.512-1.872 0L16 13.516l-6.54 6.01c-.518.51-1.356.51-1.873 0-.516-.513-.517-1.343 0-1.855l7.476-7.326c.517-.512 1.356-.512 1.873 0l7.476 7.327c.516.513.516 1.342 0 1.854z"/></svg>
      </a>
    </div>

    <script type="text/javascript">
  // global vars
  var g_base_url = 'habrahabr.ru';
  var g_show_xpanel = false;
  var g_base_fullurl = 'https://habrahabr.ru/';
  var g_is_guest = false;
  var g_is_enableShortcuts = '1'

</script>

    <script src="https://habracdn.net/habr/javascripts/1504775151/app.vendors.js"></script>
    <script src="https://habracdn.net/habr/javascripts/1504775151/app.main.js"></script>
      <script type="text/x-mathjax-config">
  MathJax.Hub.Config({
    showProcessingMessages: false,
    showMathMenu: true,
    tex2jax: {
      inlineMath: [['$inline$','$inline$']],
      displayMath: [['$$display$$','$$display$$']],
      processEscapes: true
    },
    MathMenu: {
      showRenderer: true,
      showContext:  true
    }
  });

  MathJax.Extension.Img2jax = {
    PreProcess: function (element) {
      var hasMath = false;
      var images = element.querySelectorAll('[data-tex]');
      for (var i = images.length - 1; i >= 0; i--) {
        var img = images[i];
        var tex = img.alt.replace(/(\r\n|\n|\r)/gm, " ");
        if (tex && tex[0] === '$'){
          var script = document.createElement("script"); script.type = "math/tex";
          hasMath = true;
          if (img.getAttribute('data-tex') == "display"){script.type += ";mode=display"}
          MathJax.HTML.setScript(script, tex.substring(1,tex.length-1));
          img.parentNode.replaceChild(script,img);
        }
      }
    }
  };

  MathJax.Hub.Register.PreProcessor(["PreProcess", MathJax.Extension.Img2jax]);
</script>

<script type="text/javascript"
  src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js?config=TeX-AMS_SVG-full&locale=ru">
</script>

  <script type="text/javascript" src="https://habracdn.net/habr/javascripts/1504775151/libs/highlight.pack.js"></script>


      <script type="text/javascript">
        $(document).ready( function(){
          window.tmidLogin = function(){ return false; };
          if( $.cookie('tmid_no_check') == undefined ) {
            var expire = new Date();
            expire.setMinutes(expire.getMinutes() + 10 );
            $.cookie('tmid_no_check', 1, { expires: expire } );
            $.getScript("https://id.tmtm.ru/checklogin/", function(){
              if( window.tmidLogin() ) {
                var href = $('#login').attr('href')+'?checklogin=true';
                if( href !== undefined ) { window.location.href = href; }
              }
            });
          }
        });
      </script>

      <script type="text/javascript" src="https://habrahabr.ru/viewcount/post/336730/"></script>

    
<!-- Yandex.Metrika counter -->
<script type="text/javascript">
(function (d, w, c) {
    (w[c] = w[c] || []).push(function() {
        try {
            if (typeof (_yaparams) != 'undefined') {
                w.yaCounter24049213 = new Ya.Metrika({id:24049213,
                    webvisor:true,
                    clickmap:true,
                    trackLinks:true,
                    accurateTrackBounce:true,
                    params:_yaparams});
            } else {
                w.yaCounter24049213 = new Ya.Metrika({id:24049213,
                    webvisor:true,
                    clickmap:true,
                    trackLinks:true,
                    accurateTrackBounce:true});
            }

        } catch(e) { }
    });

    var n = d.getElementsByTagName("script")[0],
        s = d.createElement("script"),
        f = function () { n.parentNode.insertBefore(s, n); };
    s.type = "text/javascript";
    s.async = true;
    s.src = (d.location.protocol == "https:" ? "https:" : "http:") + "//mc.yandex.ru/metrika/watch.js";

    if (w.opera == "[object Opera]") {
        d.addEventListener("DOMContentLoaded", f, false);
    } else { f(); }
})(document, window, "yandex_metrika_callbacks");
</script>
<noscript><div><img src="//mc.yandex.ru/watch/24049213" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<!-- /Yandex.Metrika counter -->

    
    
  </body>
</html>
