Какие версии Java вы используете?

    С прошлого аналогичного опроса прошёл целый год, и пришла пора его повторить и немного расширить. Особенно при учёте того, что для Java 7 скоро перестанут выпускать обновления.

    Под катом этого поста, как и предыдущего, находятся разнообразные опросы и сборники предсказаний. По результатам голосований этого года мы сможем посмотреть, насколько близки к истине оказались в прошлый раз.

    Пожалуйста, если вы вообще не используете java, нажимайте «воздержаться», чтобы не портить статистику.

    Результаты прошлого опроса
    Прошлый опрос был произведён 14 февраля 2014 года. Java 8 была выпущена 18 марта 2014 года, то есть на 1 месяц и 4 дня позже, чем был проведён опрос.















    Сам опрос оказался под катом:
    Используете ли вы Java <8?
    Используете ли вы Java 8?
    Используете ли вы Java 9?
    Оцените свою убеждённость: «к 16 февраля 2016 года я буду использовать Java 8 в production»
    Оцените свою убеждённость: «к 16 февраля 2016 года я буду использовать Java 9 в production»
    Оцените свою убеждённость: «к 16 февраля 2017 года я буду использовать Java 9 в production»
    Какие версии Java EE вы используете?
    Какие версии Java EE поддерживает ваш сервер?

    Только зарегистрированные пользователи могут участвовать в опросе. Войдите, пожалуйста.

    Поделиться публикацией
    Похожие публикации
    AdBlock похитил этот баннер, но баннеры не зубы — отрастут

    Подробнее
    Реклама
    Комментарии 12
    • +4
      Предполагаю, что java 8 в основном используют те, кто не использует Java EE. Передаю привет WebSphere!
      • 0
        IBM Java 8 зарелизится в марте этого года.
        Ну а чуть попозже, скорее всего, подтянут новый релиз WebSphere Application Server.

        Сейчас можно на любой Java (не обязательно IBM) версии 6 и выше (а значит и 8) запускать IBM WebSphere Application Server 8.5.5 (Liberty Profile).
        • 0
          IBM JDK 8 выпустили 11 февраля.
          http://www.ibm.com/developerworks/java/jdk/linux/download.html
          Но на большинстве продуктов, например BPM и 7-я версия пока не работает.
          • 0
            11-го февраля — не под все платформы.

            Все логично. После релиза JDK должно пройти время до релиза нового WAS (Full Profile), а потом еще и время до выпуска новых версий продуктов, которые на нем основаны. (Portal, BPM и т.п.) Поэтому смело плюсую полтора-два года до появления Java 8 в том же BPM.

            Для «нетерпеливых» есть WAS (Liberty Profile), который пока свободен от Legacy-совместимости и может быть «на фронте» новых технологий. Но, на основе WAS (Liberty Profile) пока вроде бы нет производных продуктов.
        • 0
          JBoss EAP 6.3.3 оффициально поддерживает восьмую яву
        • +4
          Под Android не доступна Java 8
          • –1
            вот этот проект делает сборку под Android даже для Java 8, правда в рамках портирования JavaFX.
            • 0
              а ещё можете попробовать вот такой плагин для Gradle
            • 0
              Интересно, Oracle Java ME Embedded для Windows 10 Mobile будет?
              • +2
                Чтобы оценить убежденность насчет Java 9, необходимо знать дату ее релиза и end-of-life Java 8.
                • 0
                  Java последних версий стала просить сертификат к приложению, которое было написано лет 10 назад и никаких авторов которого не осталось. Потому перехода с Java 6 у меня на работе не будет. Можно внести в исключения, но при этом пользователи всё равно вынуждены постоянно наблюдать диалог с предупреждением. Так что более свежие версии Java будут у нас только с переходом на новый рабочий софт. Можно было бы заморочиться и юзать две версии одновременно, но это достаточно неудобно.
                  • +1
                    радует что все таки тех кто «Я не использую Java EE» — больше, разработка без ee-контейнеров и с онными — зачастую 2 большие разницы не в пользу последних как известно

                    Интересно вторая половина у кого ee6 или ee7 получили это по каким причинам, варианты:
                    1) по «политическим»(проплаченные контракты с вендорами вебсфер и тд.)
                    2) «историческим» (страшный legacy)
                    3) ну и самая интересная причина: осознанный выбор.

                    Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.