Пользователь
0,0
рейтинг
8 января в 13:24

Разработка → VoIP + Cisco Packet Tracer из песочницы



Работая с программой Cisco Packet Tracer, часто замечал в ней различные телефонные устройства, а также ПО на клиентских устройствах, при помощи которого, можно организовывать телефонные звонки. В связи с этим, возникла идея смакетировать сеть, состоящую из всех устройств данного симулятора (cisco packet tracer 6.2), которые могут звонить и принимать звонки. При написании данной статьи, возник вопрос: «Можно ли подготовиться к экзамену CCNA Voice, при помощи данной программы?». И на этот вопрос, я постараюсь ответить в данной статье.

Используемые устройства:

1) Маршрутизатор 2811 (он будет являться DHCP сервером, VoIP шлюзом и TFTP сервером)
2) Коммутатор 2960 (в него будут подключены все устройства)
3) Аналоговый телефон (который будет подключен к коммутатору через шлюз)
4) IP телефон 7960
5) Клиентский компьютер (который будет работать, при помощи ПО Cisco IP Communicator)
6) Wi-Fi точка (она нужна для подключения к сети беспроводных устройств)
7) Ноутбук, планшетный компьютер и смартфон (данные устройства будут подключаться к Wi-Fi точке и работать через CIPC)

Далее понадобятся мак адреса всех устройств. Для компьютеров и других устройств (не телефонов), есть несколько способов узнать мак адрес. Например зайти в командную строку устройства и набрать ipconfig /all или зайти на вкладку config и скопировать в буфер мак адрес соответствующего интерфейса.





Для телефонов, я нашел только один способ — это навести мышкой на устройство и запомнить его мак (если кто знает еще способ, буду рад узнать).



Настроим роутер:

1) Повесим ip адрес на интерфейс (он будет являться шлюзом)

interface FastEthernet0/0

ip address 10.3.0.1 255.255.255.0

no shutdown


2) Дальше будем поднимать DHCP, поэтому заранее исключим из выдачи адрес, висящем на нашем интерфейсе

ip dhcp excluded-address 10.3.0.1

3) Поднимем DHCP

ip dhcp pool Telephony

network 10.3.0.0 255.255.255.0 (анонсируем сеть)

default-router 10.3.0.1 (указываем основной шлюз)

option 150 ip 10.3.0.1(указываем tftp сервер)


4) Поднимем телефонный сервис и настроим на нем кол-во телефонов и кол-во линий (несмотря на то, что устройств у нас 6, укажем количество с запасом)

telephony-service (поднимаем CME)

max-ephones 10 (указываем кол-во телефонов)

max-dn 10 (указываем кол-во линий)

ip source-address 10.3.0.1 port 2000 (указываем с какого интерфейса он будет принимать звонки)

auto assign 1 to 10 (назначаем автоматическое присвоение линий от 1 до 10)


5) Теперь настроим линии

ephone-dn 1 (создаем линию)

number 101 (присваиваем ей номер)

!

ephone-dn 2 (создаем линию)

number 102 (присваиваем ей номер)

!

ephone-dn 3 (создаем линию)

number 103 (присваиваем ей номер)

!

ephone-dn 4 (создаем линию)

number 104 (присваиваем ей номер)

!

ephone-dn 5 (создаем линию)

number 105 (присваиваем ей номер)

!

ephone-dn 6 (создаем линию)

number 106 (присваиваем ей номер)


6) Теперь создадим телефоны и привяжем определенный номер к мак адресу телефона
ephone 1 (для аналогового телефона)

device-security-mode none

mac-address 0060.2FD6.7601 (мак адрес шлюза аналогового телефона)

type ata (указывает, что телефон аналоговый)

button 1:1 (привязывает данный телефон к первому номеру, то есть 101)

!

ephone 2 (для ip телефона)

device-security-mode none

mac-address 0030.A3EB.2305 (мак адрес ip телефона)

type 7960 (указывает, что это cisco 7960)

button 1:2 (привязывает данный телефон ко второму номеру, то есть 102)

!

ephone 3 (для компьютера)

device-security-mode none

mac-address 0001.C7DE.62B5 (мак адрес компьютера)

type CIPC (указывает, что будет использоваться программа cisco ip communicator или коротко cipc)

button 1:3 (привязывает данный телефон к третьему номеру, то есть 103)

!

ephone 4 (для смартфона)

device-security-mode none

mac-address 0001.4315.ED82 (мак адрес смартфона)

type CIPC (указывает, что будет использоваться программа cisco ip communicator или коротко cipc)

button 1:4 (привязывает данный телефон к четвертому номеру, то есть 104)

!

ephone 5 (для планшета)

device-security-mode none

mac-address 00D0.BC92.7B76 (мак адрес планшета)

type CIPC (указывает, что будет использоваться программа cisco ip communicator или коротко cipc)

button 1:5 (привязывает данный телефон к пятому номеру, то есть 105)

!

ephone 6 (для ноутбука)

device-security-mode none

mac-address 0001.9622.8276 (мак адрес ноутбука)

type CIPC (указывает, что будет использоваться программа cisco ip communicator или коротко cipc)

button 1:6 (привязывает данный телефон к шестому номеру, то есть 106)


Настроим коммутатор:

1) Переведем 4 порта коммутатора, которые смотрят на наши устройства в голосовой влан

interface FastEthernet0/1

switchport voice vlan 1

exit

!

interface FastEthernet0/2

switchport voice vlan 1

exit

!

interface FastEthernet0/3

switchport voice vlan 1

exit

!

interface FastEthernet0/4

switchport voice vlan 1


Настроим VoIP шлюз аналогового телефона:

Так как данный аналоговый телефон не умеет работать с IP адресами, но ему надо получить номер, он подключается к сети при помощи шлюза. Для корректной работы, шлюзу нужно прописать адрес сервера, куда обращаться.

"

Настройка Wi-Fi

Так как на данных переносных устройствах нету ethernet портов, то работать они будут при помощи wi-fi точки, соединенной с общей сеткой. Подключаем точку к коммутатору и заходим в ее настройки.

Кликаем по вкладке Config -> Port 1 и настраиваем (в целом можно оставить название Default и без пароля):

SSID: wifi
Channel: 6
Authentication: WPA2-PSK
PSK Pass Phrase: cisco123




Теперь вводим эти данные на устройствах, которые будут подключаться по wi-fi. Например настроим wi-fi на смартфоне. Кликаем по вкладке Config -> Wireless0 и настраиваем. Убедитесь, что галочка напротив port status стоит в положение On, и в поле IP Configuration выбрано DHCP.

SSID: wifi
Channel: 6
Authentication: WPA2-PSK
PSK Pass Phrase: cisco123




Получение адресов и настройка CIPC на устройствах:

На данном этапе телефоны уже должны зарегистрироваться и получить номера (во вкладке GUI, в правом верхнем углу должен появиться номер полученного телефона).

Аналоговый телефон:



IP телефон 7960:



Перейдем к компьютеру и другим устройствам.После того как все устройства получат IP адреса, переходим на вкладку Desktop и выберем Cisco IP Communicator. После этого в правом верхнем углу видим, что номер присвоен (лично у меня номер не присваивался до момента, пока не запустишь сам CIPC. То ли это глюк самого симулятора, то ли Cisco хотела имитировать, что номер присваивается после запуска клиента)

Но в целом картинка такая:

ПК:



Смартфон:



Планшет:



Ноутбук:



Как видим, все устройства получили номера, согласно резервациям на маршрутизаторе.

Проверка работоспособности:

Остался финальный этап, в виде организации телефонного звонка и соединения. Но проверять все 6 устройств и звонки с каждого на каждый нецелесообразно, так как получится целый диафильм. Поэтому организуем звонок с планшетного компьютера на обычный аналоговый телефон и наоборот, а также с аналогового телефона на ip телефон и обратно.

Звонок с планшета на аналоговый телефон (с номера 101 на 105):



Звонок с аналогового телефона на планшет (с номера 105 на 101):



Звонок с аналогового телефона на IP телефон (с номера 101 на 102), причем здесь трубка специально поднята для демонстрации, что соединение установлено и возможен разговор.



Звонок с IP телефона на аналоговый телефон (с номера 102 на 101):



Тем самым организовали телефонное соединение, как схожих по структуре устройств, так и совершенно разных по своей архитектуре аппаратно и программно.

P.S. И вот мы подошли к концу и остается ответить на вопрос, заданный в начале: «Можно ли подготовиться к экзамену CCNA Voice, при помощи данной программы?».

Постараюсь ответить немного развернуто. Пока писал данную статью, немного разочаровался. Так как в данном симуляторе присутствует только один роутер, на котором можно поднять CME и организовать телефонию- это 2811. Вдобавок к этому, функциональность данного роутера урезана донельзя, соответственно макетировать тут можно только самые базовые вещи. Говорить о телефонах думаю нет смысла. Ну а если говорить о самой программе Cisco IP Communicator, то здесь она не больше чем картинка с парой кнопок. Соответственно считаю, что для подготовки к экзамену, опыта, полученного в данном симуляторе, будет явно недостаточно и придется использовать более мощные инструменты. Но для базового ознакомления с тем, как работает цисковская телефония, она справляется.
В связи с этим в дальнейшем планирую выпустить урок по Cisco Call Manager или CUCM, а также более детально разобрать функционал программы CIPC.

Всем спасибо и удачных настроек.
@solid_93
карма
9,0
рейтинг 0,0
Реклама помогает поддерживать и развивать наши сервисы

Подробнее
Реклама

Самое читаемое Разработка

Комментарии (2)

  • +1
    Для телефонов, я нашел только один способ — это навести мышкой на устройство и запомнить его мак (если кто знает еще способ, буду рад узнать).

    Можно же на самом коммутаторе дать команду show mac address-table [interface fa0/X] и посмотреть.
    • 0
      Да, согласен. Можно и предложенным вами способом.

Только зарегистрированные пользователи могут оставлять комментарии. Войдите, пожалуйста.