Альфа-версия qutIM 0.2 ждёт вас

    Спустя месяцы тяжелой разработки, преодоленные проблемы с сервером и другие встреченные трудности, разработчики кроссплатформенного IM-клиента qutIM рады сообщить о выходе версии 0.2-альфа.
    image


    Немного о том, что же за 0.2 версия

    В первую очередь стоит отметить, что это абсолютно новое ядро, то есть, код нового кутима написан с нуля и не имеет никакого отношения к версии 0.1.1.

    Стоит ли переходить на 0.2 версию?
    Стоит, так как новая версия мощнее, гибче и обладает большим количеством возможностей, нежели старая.
    Кратко о возможностях новой версии.

    Внешний вид программы


    • Поддержка смайл-паков от Копете
    • Поддержка стилей оформления для контакт-листа
    • Поддержка смены формы для окон чата (смена расположения кнопок, добавление/удаление не нужных и прочее)
    • Поддержка стилей Адиум и Копете для логов чата
    • Поддержка стилей для всплывающих уведомлений
    • Поддержка статус-паков от Адиум
    • Поддержка паков иконок для всего приложения
    • Поддержка переводов
    • Поддержка стилей для всего приложения
    • Поддержка тем обрамления для контакт-листа

    Новые возможности программы


    • Поддержка профильности (возможность создать свой так называемый контейнер с индивидуальными настройками, стилем программы и набором аккаунтов)
    • Расширенные возможности контакт-листа
      • возможность отображать текст статусов прямо в контакт-листе под ником контакта
      • отображение аватар контактов
      • возможность смены местами групп
      • перетаскивание мышкой контактов из группы в группу
      • выделение контакта по набору букв с клавиатуры
      • и многое другое )
    • Расширенные возможности окна чата и оптимизирование работы
      • контекстное меню контакта из окна чата
      • поддержка форм сделанных в Qt Designer
      • более оптимизированное использование оперативной памяти в табовом режиме, чем было раньше
    • и многое другое

    Но самым главным введением является расширяемость при помощи сторонних плагинов.

    На данный момент существуют следующие протокольные плагины:

    ---ICQ
    • поддержка х-статусов
    • передача файлов
    • статусы приватности
    • поддержка приватных списков, списки видимости, невидимости
    • поиск пользователей
    • и т. д.


    ---Jabber/LiveJournal/Yandex/GTalk
    • Передача файлов
    • Настроения
    • Деятельность
    • Ad-Hoc
    • Поиск сервисов/конференций
    • Поддержка транспортов
    • Поиск пользователей
    • Приглашения в конференции


    ---Mail.Ru
    • Прием/отправка сообщений
    • Исходящие/входящие нотификации о вводе
    • Подтверждение о доставке сообщения
    • Отправка/обработка сообщений авторизации
    • Поддержка RTF сообщений (только текст)
    • Поддержка оффлайн-сообщений
    • Получение оповещений о новых письмах в ящике
    • Вход в почтовый ящик из клиента (без авторизации на сайте)
    • Добавление/Редактирование/Удаление контактов
    • Поиск контактов
    • Информация о контактах
    • Аватары
    • Возможность отправки СМС сообщений


    ---IRC
    • конференции
    • приватные чаты
    • основные команды (/me, /nick, /join, etc.)
    • CTCP команды
    • и др.


    На данный момент добавление функционала заморожено и начинается отлавливание и исправление критических ошибок. О найденных ошибках с подробным описанием писать на трак программы trac.qutim.org

    Внимание! Багом не являются сообщения: «А вот в таком-то клиенте вот так, а у вас не так, было бы хорошо сделать», «хотелось бы», «у меня чё-то где-то тормозит», «чё-то сегфолтит иногда», «чё-то как-то вроде где-то как бы».
    Для выполнения ваших желаний и хотелок у вас есть сообщество, не надо доставать разработчиков своими просьбами.

    Ссылки:
    qutIM + ICQ 0.2 alpha для Windows — qutim.org/uploads/qutim_icq_0.2_alpha.exe
    qutIM + ICQ, Jabber, IRC, Mail.ru 0.2 alpha для Windows — qutim.org/uploads/qutim_full_0.2_alpha.exe
    qutIM 0.2 alpha source — qutim.org/uploads/qutim_0.2_alpha_source.tar.bz2

    P.s. от torkve: пакеты для Debian уже готовятся.

    P.p.s. Парочка кликабельных скриншотов:



    P.p.p.s. Пользователем Q2W были собраны пакеты qutim и jabber для пользователей ubuntu i386, пользуйтесь:
    qutim_0.1.99.179-1_i386.deb
    qutim-dev_0.1.99.179-1_all.deb
    qutim-protocol-jabber_0.1.99.179.283-1_i386.deb
    qutim-protocol-jabber-dev_0.1.99.179.283-1_all.deb
    Поделиться публикацией
    Похожие публикации
    Реклама помогает поддерживать и развивать наши сервисы

    Подробнее
    Реклама
    Комментарии 362
    • +44
      это лучший im под linux, из тех которые я видел. рад что он развивается
      • +3
        Не только под линукс!
        Ребята, просто отлично, так держать! Хорошо бы только ещё конвертор истории с QIP и вообще всё зашибись!
        Готов к миграции ;)
        • 0
          присоединяюсь, аналогично хочется эмигрировать в такую замечательную сборку из QIP Infum. И будет ли вообще локализация данной программы? если да, то когда?
          • 0
            Локализация есть на форуме, там же написано, что куда ставить.
            • 0
              почему нет сайта как такового, где бы все расписали по полочкам??
              сунулся конвертировать хистори из квипа при помощи выложенного на форуме конвертера — конвертирует в xml корректно — все читается — но вот в самом кутим 0.2 полная бредятина а не текст.
              согласен, может я «поторопился» и конвертер для версии 0ю2 еще не написан, но вот незадача НИГДЕ про это не написано! ни в какую версию происходит конвертация, ни то что формат храниния изменился кординально!

              ЗЫ и вообще при попытке хоть что-то понять как оно все это работает испытываешь нереальный информационный голод и непонимание — аж трясет
              • 0
                Потому что нет людей, которые бы всё сделали и всё написали. Хотите — вы займётесь этим и поможете всем тем, кто так же как и вы, не может ничего найти? Напишете нормальный FAQ, мануалы, распишете всё по полочкам.
                • 0
                  Раз уж на то пошло, у меня не получилось даже после регистрации добавить новый ticket у вас в Trac. Forbidden, говорит, привилегий у пользователя нет.

                  Тогда напишу сюда. Такая минорная проблема — при включении в окне настроек (а не в окне диалога) отправки сообщений по энтеру, опция начинает работать только после закрытия всех закладок чата. Если не закрывать окно чата и открыть новую вкладку — опция к ней также не применится.
                  • 0
                    Это нормально, настройки-то единые для всего окна, а не вкладки.
      • +1
        спасибо! внешний вид уже привлекает. буду тестить :)
        • +16
          Поставил версию под Windows. Ребята, это отличная заявка на идеальный IM-клиент! Так держать!
          • 0
            да, заявка отличнейшая. только еще сирая несколько.
            но — респект!!))
          • 0
            скачал с сайта смайлы, положил в папку, в настройках интерфейса ничего не появляется.
            как?)
            • 0
              В какую папку и какая система?
              • 0
                А в какую надо? Windows.
                • +2
                  Есть два варианта:
                  1) \Documents and Settings\%username%\Application Data\qutim\emoticons\%smilepackname%\
                  2) qutim\emoticons\%smilepackname%\

                  Вместо %smilepackname% будет имя скачанной папки со смайлами.
                  Второй вариант удобно использовать, когда вы кутим таскаете с собой на разные компьютеры — папка emoticons у вас лежит прямо в папке кутима. Если вы еще создадите в папке с кутимом папку config, то у вас туда же будут класться и настройки, получится portable-версия.
              • 0
                win xp
                qutIM\imageformats\
                и потом qutIM\imageformats\Tango-smile
                никакого эффекта
                • +1
                  Смотрите чуть выше, я ответил :)
                • 0
                  лучше скажите куда и как надо :)
                  • –2
                    Я в Linux не разобрался куда смайлы и звуки ложить.
                    он не создал в домашнем каталоге папку .qutim :(
                    • +1
                      ~/.config/qutim
                      • +1
                        эх… когда уже все конфиги перелезут туда? :)
                  • 0
                    там не все сразу появляется вообще :) для изменения отправки по ентеру и настроек уведомления, мне пришлось перезапустить клиент.
                    • –1
                      Для изменения отправки по-моему достаточно закрыть и открыть окно чата, хотя не уверен, не проверял.
                  • +3
                    Не пользовал, но одобряю)

                    Ребят, хотелось-бы спросить, а он тему оформления рабочего окружения подхватывает, или выделяется оформлением?
                    • +6
                      У него есть в настройках три варианта: системное оформление, оформление темой кутима, и вообще убрать оформление нафиг
                      • 0
                        Спасибо, сегодня-же и попробую)
                    • +2
                      Спасибо, уже пару месяцев сижу на кутиме =)

                      В репозиторий убунтовский новая версия попадет?
                      • +1
                        Надо спросить тех, кто поддерживает убунту. Могу сказать точно, что в 9.04 уже не попадёт, там давно закрыт приём новых пакетов, а вот в 9.10 вполне возможно :)
                        • 0
                          Это, как я понимаю, в официальный. А так, между нами? Есть какой-то реп?
                          • 0
                            Ну, я поддерживаю исключительно дебиановский, который с недавнего времени стал несовместим с убунтовским. Убунтовский создать я пока не могу по причинам, уже не раз упомянутым в комментах. Чтобы кто-то поддерживал сторонние репы. я не видел.
                      • 0
                        Файлопередача все время валит клиент при приеме в момент после установки соединения в самом начале передачи файлов. Наблюдаю довольно давно.
                        • 0
                          Хмм, ни разу не наблюдал. Скажите, пожалуйста, какая у вас ОС, версия QT и через какой протокол вы шлёте файлы?
                          • 0
                            x86_64 2.6.28-ARCH, qt 4.5.0-1, qutim из свн стал использовать недавно, протокол icq (c jabber -ом не пробовал, слабоват он пока в кутиме, потому не использую)
                            Версии ядра и qt менялись, но проблема осталась.
                            • +2
                              Запустите, пожалуйста, кутим через «gdb qutim» в консоли, после этого наберите «run», а когда кутим упадёт — наберите «where» и пришлите вывод. Лучше сразу на trac.qutim.org.
                              • 0
                                Обновился предварительно из свн, запустил в отладчике. Кутим не упал, но при передаче вышло imagebin.ca/view/fpZULl.html и файл размером 0 байт в итоге. Когда попробовал без отладчика, то все тоже самое только кутим секунд через 10 упал. Пока не могу никого допроситься помочь с проверкой. Позже поэкспериментирую еще.
                                • 0
                                  Возможно, лаг из-за того же, из-за чего падала раньше миранда — наличие НЕ латинский символов в названии файла?
                                  • 0
                                    Вот название одного, остальные потер [AllCDCovers]_radiohead_in_rainbows_2007_custom_cd-back.jpg
                                    • 0
                                      Проверил только что, Вин семь, х64, падает при старте любой передачи, но отправляет багрепорт.
                                      • 0
                                        Рустам просил передать, что он не получает багрепортов из винды, поэтому шлите, пожалуйста, их ему на почту — qutim.develop собачка gmail.com
                        • +2
                          ура. несмотря на то, что большую часть времени вынуждена общаться с виндой, qutIM всё равно запал в душу :)
                        • 0
                          Спасибо огромное!
                          • –1
                            Черт, мне очень понравился клиент! Сюда бы еще смайлы в комплект (а не скачивать отдельно), в верхнюю часть окна поставить более знакомые иконки, вынести туда кнопку для перехода в меню настроек, и еще уведомление о наборе приходит иногда несколько раз в секунду, а так пока все круто :)
                            • 0
                              Вроде бы сейчас делают плагин для установки разных паков прямо из кутима — на манер КДЕ.
                              • –1
                                смайлы только пнг?
                                из квина, например, гифы не стащить :(
                                • 0
                                  Нет, не только. Более того, готовые смайлпаки с квиповскими смайлами давно лежат на форуме.
                              • +3
                                И получится QIP… И зачем тогда это надо? )
                                • +1
                                  Кроссплатформенный, расширяемый не хуже миранды квип :) И вы еще спрашиваете, зачем это надо?)
                                  Кто бы только хорошие смайлы нарисовал, вот в чём проблема.
                                  • +2
                                    Колобок уже не устраивают? )
                                    • 0
                                      Они несвободные, более того, их по лицензии нельзя распространять вместе с программой, только в виде отдельных готовых паков.
                                  • 0
                                    Поправка: получится свободный квип.
                                    В надежности которого нельзя будет сомневаться по причине наличия свободных исходных текстов. Какие гарантии могут дать нам разрабы квипа, что их программа не будет воровать пароли или содержать в себе вредоносные закладки для входа в систему? Правильный ответ — никаких. Ибо исходный код программы закрыт и удостовериться в ее надежности не представляется возможным
                                    • –2
                                      Для меня qip — ругательство. Давайте не будем сравнивать качественный и свободный продукт с этой… хм… поделкой. :)
                                      • +1
                                        товарищ параноик? Тогда пользователи Windows, которые скачивают именно бинарики, а не исходный код, откуда могут быть уверенны, что данная сборка именно из свн и там не добавлен вредоносный код? А ещё совсем непонятна для чего тому же QIP пароли воровать с такой-то аудиторией большой… чтобы уменьшить её и опустить себя, как продукт?
                                        Нет-нет, я не защитник квипа, просто не понимаю таких высказываний.
                                        • +1
                                          Я не параноик, но основания для этого по-крайней мере, в данном случае имеются.
                                          То, что вы предполагаете, что завтра или в любой другой день, закрытые программы будут работать точно также, как и сегодня, еще не означает, что в этих программах нет вредоносныхх закладок.
                                          • 0
                                            так же открытый код не означает, что в продукте, который собран разработчиками под туже Windows, Debian etc нет вредоносного кода.
                                            • +1
                                              Правильно, я с вами согласен. Только вы не учитываете одной вещи — до того, как такая программа попадет в хотя бы testing ветку дебиана, пройдет гораздо большее время на проверку кода, исключение их этого кода ошибок и ляпов и проч. в еще экспериментальной и нестабильной ветках совершенно другими людьми, но их будет достаточно для того, чтобы выявить к примеру, вредоносный код.
                                            • +1
                                              Вы на улице от незнакомых людей не шарахаетесь?
                                          • 0
                                            А вы читаете исходники всех программ которые устанавливаете себе?
                                      • 0
                                        Ещё хотел спросить — а в сторону Telepathy-Qt разработчики пока не смотрят? Просто собираю информацию о нём)
                                        • +2
                                          Дословный комментарий:
                                          «я не смотрел и вообще не знал о нем и тем более не знаю для чего он мне»
                                          • +1
                                            Абстракция над сетевыми протоколами от freedesktop.org
                                        • 0
                                          Windows7 — icq
                                          бывает такой глю:
                                          номер в онлайне, но все контакты показываются как «не в сети». Лечится переподключением(иногда пару раз приходится)
                                          • +1
                                            ура ура ура =)))) мой любимый qutIM добрался до альфа версии. Не в обиду другим, но это, на мой взгляд, самый удобный мессенджер под линухом =)
                                            • +1
                                              по фунциональности напоминает миранду, что ж, нужно попробовать )
                                              • +2
                                                О, если бы вы знали что там еще планируется :) Я нежно люблю миранду, но боюсь, что кутим ее обойдёт по расширяемости :)
                                                • 0
                                                  Интересное заявление :) Буду ждать, хотелось бы, чтобы у миранды появился достойный соперник.

                                                  Вы тогда о новых версиях сообщайте, а я пока пойду пробовать эту.
                                                  • 0
                                                    Он не соперник миранда, т.к. последняя Windows Only, да и сомневаюсь, что в за один день Кутим обойдет многолетне развивающееся комьюнити поддержки и расширения миры. Тем не менее — удачи ему.
                                                  • 0
                                                    только миранда далеко не кроссплатформенный клиент и в сравнение просто не идёт…
                                                    • +1
                                                      Не кроссплатформенный. По этой причине, например, она имеет возможность использовать windows-specific вещи, которых нигде больше нет. Во всём есть свои плюсы и минусы :)
                                                      • –1
                                                        Один из огромных плюсов это native =) Да-да. Люблю программы на API, а не из обвесок.
                                                • +1
                                                  а чего это мак версии убрали?
                                                  • +2
                                                    Как то не хорошо, раз кроссплатформеный, мак тоже должен быть.
                                                    • 0
                                                      Поддерживать некому. У разработчиков нету мака, а из сообщества маководов не нашлось хороших программистов, чтобы поддерживать. Периодически какие-то пакеты собираются — посмотрите на форуме — но нормальной поддержки никто не осуществляет.
                                                      • 0
                                                        Это, между прочим, очень жаль.
                                                        • +3
                                                          Это к сообществу. У программы всего два человека разрабатывает ядро. Плюс один художник, плюс разработчики плагинов — итого 7 человек вместе со всеми плагинами. Я поддерживаю весь сайт и деб-пакеты. И ни у кого из нас, заметьте, нету мака :) Каким образом должна осуществляться поддержка?
                                                          Вот вы, как макопользователь, не хотите заняться сборкой qutIM под мак? И никто из сообщества почему-то не хочет.
                                                          • 0
                                                            Я просто в этом ничего не понимаю. Если бы понимал — занялся бы, почему нет.
                                                            • +7
                                                              Дык вот и никто не понимает. Подарите мне мак, я с удовольствием разберусь и соберу кутим под мак :)
                                                              • 0
                                                                Я, конечно, извиняюсь… но почему бы и не использовать «хакинтош»? Существуют легко устанавливаемые на PC сборки того же Mac OS X 10.5, например, Leo4All. Начать можно с www.osx86project.org
                                                                • +8
                                                                  Вот я вам сейчас скажу такую вещь, которая, несмотря на свою правдивость, вас и очень большое число людей из «сообщества» обидит. Понимаете, ни мне, ни разработчикам хакинтош в пень не упёрся. Нам он просто не нужен. Маков у нас нету. Именно по этой причине мы не будем задумываться над сборкой пакетов. Я занимаюсь той частью, которая нужна мне и с которой я могу помочь. Мне нужны пакеты для Debian — я их собираю и заодно помогаю сообществу, выкладывая их в сеть. Рустаму пришлось пересесть с gentoo на windows — он занялся улучшением работы программы для windows. На форуме кутима есть один человек, которому интересно возиться с хакинтошем, он иногда пытается что-то собрать, молодец. Но почему мы должны тратить своё время на то чтобы разбираться с вещью, которой никогда не воспользуемся? Почему в огромном опенсорс-сообществе не найдётся ни один любитель макинтоша, который сядет и соберет пакет? Вот лично вы сели бы да разобрались, и всем было бы хорошо.
                                                                  Самая большая проблема воспетого Столлманом опенсорс-сообщества заключается в том, что «вокруг всем на всё наплевать» © «Ночной продавец».
                                                                  • 0
                                                                    Ну я в принципе и предполагал такой ответ… ;) но всё же задал этот вопрос.
                                                                    Но я думаю, что на сайте надо таки выложить сборку (пусть и сделанную сообществом) отдельной ссылкой в downloads или хотя бы дать ссылку на форум, где это обсуждается. Добавьте примечание, что это contrib build.
                                                                    Сам я могу собрать, но сейчас пока не работаю на Mac-е. :(
                                                                    • 0
                                                                      Вот соберите, с удовольствием выложим. Человек, который делал сборки мака, жалуется, что они у него какие-то глючные. Плюс при выходе там программа как-то падает и маководы всё не могут отловить бэктрейс вроде бы.
                                                      • 0
                                                        А зачем mac-версия? Adium'a не хватает? :) Приведу аналогию: выпускается новый медиа-плеер с поддержкой скинов от так любимому большинству винампа, но тем не менее, чего-то то да не хватает для комфортной работы, не дотягивает до уровня оригинала (т.е. винампа), до которого хотят доростить этот новый проигрыватель. То же самое и здесь, зачем версия под mac, когда уже все изобретено и сделано лучше? :)
                                                        P.S. Для линукосидов выпуск этой версии — явный прорыв, т.к. ни pidgin, ни kopete уже похоже не так хороши :)
                                                        • +1
                                                          >Для линукосидов выпуск этой версии — явный прорыв, т.к. ни pidgin, ни kopete уже похоже не так хороши :)
                                                          Спорный вопрос…
                                                          • +1
                                                            в pidgin и kopete банально приватных статусов нету в ICQ, и в Jabber'е много чего не хватает. Так что прорыв.
                                                            • 0
                                                              Вы о x-статусах?
                                                              Они давно уже есть kopete, причем, к сожалению, не отрубаются.
                                                              В pidgin'е, к счастью, их по умолчанию нет, но где-то я видел то ли плагин, то ли патч, добавляющий их.
                                                              • +3
                                                                при-ват-ных!
                                                                определяющих видимость вас для кого либо — видим для всех, невидим для всех, видим только для списка видимых и так далее.
                                                                • 0
                                                                  *видим только для списка видящих
                                                                  • 0
                                                                    В таком случае приношу извинения)
                                                                    Ждем pidgin на движке от quitim)
                                                              • +1
                                                                А юзабилити? Ведь именно этим и привлекает Qip. Удобством и простотой. И симпатичным интерфейсом. И этим очень сильно привлекает qutIM :)
                                                                • 0
                                                                  Юзабилити и интерфейс пиджина меня вполне устраивают, временами не устраивает функционал, в частности — нет возможности управлять транспортами джаббера и т.д.
                                                              • 0
                                                                Как ни странно, Adium для меня почему-то неудобен. ;(
                                                            • +8
                                                              /me глянул на скрины и удалил pidgin
                                                              • 0
                                                                да и не только его
                                                                вообще, пусть простят меня боги, но под линухом все IM клиенты такие убогие…
                                                                не понимаю сами разработчики их вообще используют?

                                                              • +1
                                                                у вас опечаточка вышла — LibeJournal=)
                                                                • 0
                                                                  Исправил, спасибо.
                                                                • 0
                                                                  а rpm пакеты будут?
                                                                  • 0
                                                                    Если кто-то их сделает :) На форуме есть темы с пакетами под разные дистрибутивы, посмотрите там.
                                                                    • 0
                                                                      под опенсузи 11.1 нету :(
                                                                      не могу найти как собирать данную вещь — пожалуйста помогите…
                                                                      • 0
                                                                        разобрался как собирать — падает на сборке :((
                                                                        будем ждать пакеты
                                                                        • 0
                                                                          Напишите, какая выдаётся ошибка, возможно, я смогу вам помочь.
                                                                          • 0
                                                                            [ 1%] Building CXX object CMakeFiles/qutim.dir/src/chatwindow/conferencetabcompletion.cpp.o
                                                                            In file included from /tmp/1/qutim/src/chatwindow/separateconference.h:22,
                                                                            from /tmp/1/qutim/src/chatwindow/conferencetabcompletion.cpp:22:
                                                                            /tmp/1/qutim/src/chatwindow/separatechatwindow.h:24:20: error: QWebView: Нет такого файла или каталога
                                                                            /tmp/1/qutim/src/chatwindow/separatechatwindow.h:25:21: error: QWebFrame: Нет такого файла или каталога
                                                                            In file included from /tmp/1/qutim/src/chatwindow/separateconference.h:22,
                                                                            from /tmp/1/qutim/src/chatwindow/conferencetabcompletion.cpp:22:
                                                                            /tmp/1/qutim/src/chatwindow/separatechatwindow.h:143: error: ISO C++ forbids declaration of ‘QWebView’ with no type
                                                                            /tmp/1/qutim/src/chatwindow/separatechatwindow.h:143: error: expected ‘;’ before ‘*’ token
                                                                            In file included from /tmp/1/qutim/src/chatwindow/conferencetabcompletion.cpp:22:
                                                                            /tmp/1/qutim/src/chatwindow/separateconference.h:108: error: ISO C++ forbids declaration of ‘QWebView’ with no type
                                                                            /tmp/1/qutim/src/chatwindow/separateconference.h:108: error: expected ‘;’ before ‘*’ token
                                                                            make[2]: *** [CMakeFiles/qutim.dir/src/chatwindow/conferencetabcompletion.cpp.o] Ошибка 1
                                                                            make[1]: *** [CMakeFiles/qutim.dir/all] Ошибка 2
                                                                            make: *** [all] Ошибка 2

                                                                            Linux localhost 2.6.27.19-3.2-default #1 SMP 2009-02-25 15:40:44 +0100 x86_64 x86_64 x86_64 GNU/Linux
                                                                            cmake 2.6.2
                                                                            libqt4 — 4.4.3
                                                                            make 3.81
                                                                            • 0
                                                                              Поставьте пакеты qt-webkit, qt-webkit-devel, не знаю, как они точноназываются в Suse.
                                                                              • 0
                                                                                libQtWebKit4
                                                                                Qt is a set of libraries for developing applications.
                                                                                This package contains base tools, like string, xml, and network handling.

                                                                                оно? тогда установлено и девел тоже

                                                                                версия 4.4.3

                                                                                • 0
                                                                                  та же беда на openSUSE 11.0

                                                                                  In file included from src/abstractcontactlist.h:23,
                                                                                  from src/qutim.h:25,
                                                                                  from main.cpp:18:
                                                                                  ./src/contactlist/contactlistproxymodel.h:25: error: ‘qutim_sdk_0_2’ is not a namespace-name
                                                                                  ./src/contactlist/contactlistproxymodel.h:25: error: expected namespace-name before ‘;’ token
                                                                                  In file included from src/abstractcontactlist.h:25,
                                                                                  from src/qutim.h:25,
                                                                                  from main.cpp:18:
                                                                                  ./src/contactlist/contactlistitemdelegate.h:79: error: expected ‘,’ or ‘...’ before ‘&’ token
                                                                                  ./src/contactlist/contactlistitemdelegate.h:79: error: ISO C++ forbids declaration of ‘QDomNode’ with no type
                                                                                  In file included from src/qutim.h:25,
                                                                                  from main.cpp:18:
                                                                                  src/abstractcontactlist.h:28: error: ‘qutim_sdk_0_2’ is not a namespace-name
                                                                                  src/abstractcontactlist.h:28: error: expected namespace-name before ‘;’ token
                                                                          • 0
                                                                            exterminator_tula
                                                                            URL: download.opensuse.org/repositories/home://exterminator_tula/openSUSE_11.1/
                                                                            • 0
                                                                              на форуме есть раздел по suse
                                                                              собсно оттуда и ссылка на репозиторий
                                                                              обновляется болеее менее регулярно
                                                                      • 0
                                                                        Поставил, попробовал… всем хорош (наконец то хоть какой разнообразие от квипа), только не нашел где там смайлы…
                                                                        • 0
                                                                          Смайлы надо качать с сайта и ставить :)
                                                                          • +6
                                                                            А мне даже нравятся такие смайлы (:

                                                                          • 0
                                                                            молодцы ребята
                                                                            • 0
                                                                              Спасибо =)
                                                                              • 0
                                                                                А русского языка нет?
                                                                                Пересмотрел настройки не нашел.
                                                                                • +1
                                                                                  Переводы надо качать отдельно. На форуме есть болгарский, русский, украинский.
                                                                                • 0
                                                                                  Огромное спасибо за разработку. Пользуюсь с самых первых публичных версий. 0.1.99 пользуюсь с первых дней доступности репозитория. Разработчики пробелали огромную работу и сделали очень качественный продукт. Еслинственное чего не хватает — автоконнект при запуске и реконнект при дисконнектах в жаббере (сейчас пользуюсь только ICQ и Jabber). Ну и небольшая проблема с кодировкой в аське — когда пишут из инвиза, то иногда приходит кракозябра — видимо из-за того что с инвиза не приходят капсы и определяется неправильная кодирировка.
                                                                                  • 0
                                                                                    Автоконнект можно выставить в настройках аккаунта.
                                                                                    • 0
                                                                                      Спасибо, нашел. Просто у аськи оно немного в другом месте.
                                                                                      Но нашел еще одну маленькую проблемку — окно настроек всегда поверх остальных окон кутима, в том числе и поверх окон редактирования аккаунтов.
                                                                                  • +1
                                                                                    Хм… Кто скомпилит под макось? ;)
                                                                                    • 0
                                                                                      В старой версии была ошибка подключения через прокси. и в убунте и в виндоус. попробую эту версию
                                                                                      • 0
                                                                                        ну и капча у вас на форуме, скоро сам поверю что я робот :)
                                                                                        • 0
                                                                                          Уже несколько недель собираю из SVN. Хочется пожать руку автору и всем, кто причастен к разработке — проделана действительно огромная работа.
                                                                                          • +5
                                                                                            Мы дождались кросс-платформенной миранды? =)

                                                                                            Ребята, я вас люблю!
                                                                                            • +1
                                                                                              Ура! Надеюсь, теперь будут официальные и частые снапшоты для виндовс.
                                                                                              Билды сторонних пользователей не очень нравятся. %)
                                                                                              • +1
                                                                                                Маководам то что делать?
                                                                                                • 0
                                                                                                  привет, спасибо большое за клиент, есть один вопрос: У меня панель задач находится в верхней части экрана, и когда я установил программу она начала глючить(а именно не менялся размер списка контактов, не включался звук, да и вообще никакие кнопки не нажимались), но когда панель задач перетаскиваешь в другие части экрана, будьто лево, право илил низ, все работает как обычно.

                                                                                                  P.S. я не знаю может такая проблемы только у меня попробуйте и отпишитесь у кого как)
                                                                                                  • 0
                                                                                                    1. Имхо всёже смайлы в сборку надо включить. Какой IM клиент без смайлов сейчас…
                                                                                                    2. Русский lang пак тоже не плохо бы…
                                                                                                    3. Не подскажеите, где найти готовые исходный пакет (.deb)?
                                                                                                    • 0
                                                                                                      На форуме есть тема со сборками под дебиан, заведую ей я :) Там есть ссылка на репозиторий, в котором есть в т.ч. и исходные пакеты.
                                                                                                      • 0
                                                                                                        Насколько я понял можно слить отсюда:
                                                                                                        qutim.org/debian/pool/main/

                                                                                                        :)
                                                                                                        • 0
                                                                                                          Там, насколько я понял, нет версии 0.2 :(
                                                                                                          • 0
                                                                                                            Та версия, которая там есть, в настоящий момент и есть 0.2 :) Просто там номера версий соответствуют номерам ревизий. Завтра выйдет какой-нибудь багфикс — там версия обновится, и т.д. Официальные версии я буду пакетировать только для официального дистрибутива.
                                                                                                            • 0
                                                                                                              Спасибо за разьяснения!
                                                                                                        • 0
                                                                                                          Устанавливаю из вашего репозитория. При попытке отметить для установки пакет qutim-protocol-jabber, synaptic ругается:
                                                                                                          Не удалось отметить все пакеты для установки или обновления
                                                                                                          Следующие пакеты имеют неразрешённые зависимоти.
                                                                                                          Будьте уверены, что все необходимые репозитарии добавлены и включены в настройках.
                                                                                                          qutim-protocol-jabber:
                                                                                                          Зависит: libc6 (>=2.9), но будет установлен 2.8~20080505-0ubuntu9
                                                                                                          Зависит: libgnutls26 (>=2.5.9-0), но будет установлен 2.4.1-1ubuntu0.3

                                                                                                          Все остальные пакеты установились нормально, IM очень понравился, особенно по сравнению с pidgin'ом. Возможно он когда-нить дотянет до миранды, тогда я буду вообще счастлив.
                                                                                                          • 0
                                                                                                            У вас убунта 8.10, да? Для убунты у меня сейчас нет возможности собирать пакеты, а версия gnutls, с которой компилируется яббер в дебиане, новее, из-за этого проблемы.
                                                                                                            • 0
                                                                                                              Да, 8.10.

                                                                                                              Печально. А когда появится возможность? Или эта библиотека быстрее появится в убунте в новой 9.04?

                                                                                                              Ваш репозитарий остался у меня в источнике приложений. Надеюсь, qutIM будет успешно оттуда обновляться, и скоро я смогу использовать джаббер.
                                                                                                              • 0
                                                                                                                Увы, в текущем репозитории jaunty пока что находится версии gnutls более старая, чем в дебиане.
                                                                                                                Возможность появится как только разработчики cdebootstrap в Debian исправят баг, не позволяющий создать chroot-окружение intrepid. Баг я им зарепортил, а вот исправлять они его не спешат…
                                                                                                                • 0
                                                                                                                  А со старой версией библиотеки никак не собрать плагин?
                                                                                                                  • 0
                                                                                                                    Собрать, но так у меня-то ее нет :) Я собираю пакеты в окружениях, соответствующих дистрибутиву. В lenny сейчас версия libgnutls — 2.4.2-6+lenny1, в squeeze и unstable — 2.6.4-2, то есть везде новее, чем у вас. Чтобы собрать пакет с более старой версией библиотеки, мне надо создать окружение для вашего дистрибутива — intrepid, а его-то я создать и не могу.
                                                                                                                    • 0
                                                                                                                      А Вы не собираетесь завтра принять участие в тестировании новой убунты? Просто тогда бы у вас на виртуалке как раз появилось бы нужное окружение =)
                                                                                                                      • 0
                                                                                                                        Ммм, мой нетбук, боюсь, не потянет виртуалку :) Я же собираю в чруте, а не на виртуалке.
                                                                                                                        • 0
                                                                                                                          А могу я у себя как-то собрать?
                                                                                                                          Или может быть я как-нить прокину порт-форвард до своей виртуалке, где для Вас запущу копию убунты (если нуден рут) или прямо до моей убунты (если рут не нужен).
                                                                                                                          • 0
                                                                                                                            Вы можете делать «apt-get source qutim» (аналогично для всех протоколов), потом заходить в папку с программой и набирать dpkg-buildpackage. Только для этого у вас должны стоять dev-пакеты, вам ругнутся, какие :)
                                                                                                              • 0
                                                                                                                Я тоже жду весрию под ubuntu 8.10, как только появиться upd к посту сделаете? =)
                                                                                                                • 0
                                                                                                                  Постараюсь, но боюсь, что это будет нескоро. Багрепорт в дебиане висит уже несколько недель.
                                                                                                              • 0
                                                                                                                ubuntu 9.04

                                                                                                                packages.debian.org/squeeze/libgnutls26
                                                                                                                packages.debian.org/squeeze/libc6

                                                                                                                Поставил от тестируемой ветки Дебиана, заработало :)
                                                                                                          • 0
                                                                                                            У меня контакт лист с сервера не загрузился :((

                                                                                                            Может что-то не включил в настройках?
                                                                                                            • 0
                                                                                                              В аське? Там такая ошибка имеет место быть, найти проблему и решить пока не удалось. Говорят, помогает переподключение.
                                                                                                            • 0
                                                                                                              А когда и где можно будет скачать пакеты для Debian? Для винды мне и квипа хватает выше крыши, а вот для линукса с клиентами по-хуже. Пока Pidgin, но с удовольствием опробовал бы и qutIM. Надеюсь, что пакет будет собран для текущего stable?
                                                                                                              • 0
                                                                                                                Для unstable уже есть, смотрите на форуме, для testing потом будет. Для stable… а есть ли смысл? Кутим развивается с огромной скоростью и через месяц-другой он уже будет в стейбле морально устаревший, особенно с учётом выхода qt4.5, которого в стейбле не будет. Я могу собрать один раз для стейбла, но не вижу в этом смысла.
                                                                                                                • 0
                                                                                                                  Смысл, думаю, есть, так как не все гонятся за новейшими версиями софта, и многие (в том числе и я) сидят на stable. Если соберете хотя бы од ин раз, хотябы посмотреть, что это за IM, буду благодарен.
                                                                                                                  • 0
                                                                                                                    Хорошо, соберу, но, я надеюсь, вы понимаете, что как только AOL сменит протокол, вы, если пользуетесь аськой, будете страдать :) Обновлений-то не будет.
                                                                                                              • +1
                                                                                                                Еще один момент. Просто позарез необходима проверка доставки сообщений.
                                                                                                                • 0
                                                                                                                  В невебкит-режиме она вроде бы есть, а в вебките её пока не придумали, куда приделать, чтобы сохранить совместимость с адиумовскими темами :)
                                                                                                                  • 0
                                                                                                                    Да хотя бы как статусное сообщение.
                                                                                                                    • 0
                                                                                                                      Это будет очень мерзко и неудобно — представьте себе приходящее статусное сообщение на каждое отправленное вами. Особенно если какая-нибудь девочка-школьница будет спамить смайликами свою подругу — и получать на каждый смайлик статус-сообщение «доставлено». Это ж неудобно.
                                                                                                                      • 0
                                                                                                                        Никому и не нужно знать о том что сообщение доставлено, надо знать когда оно не доставлено, имхо, статусное сообщение вполне нормально подойдет или аля миранда сделать. Например в моем случае, проблемы с сетью и порой происходит разрыв с переподключением инета, мессенджеры об этом не знают, все сообщения которые шлют мне теряются с концами, о том что сообщения мои не уходят я не знаю.
                                                                                                                        • 0
                                                                                                                          У аськи с этим проблемы — она шлёт подтверждение о доставке, но не шлёт подтверждения о недоставке. Миранда смотрит просто на таймаут и из-за этого показывает сообщение, это не совсем правильный подход.
                                                                                                                          • 0
                                                                                                                            Не совсем правильный, но за неимением другого, я согласен терпеть ложные сообщения (конечно если таймаут можно будет настраивать). Для жабы такая проблема есть?
                                                                                                                            • 0
                                                                                                                              Вроде как да, хотя не уверен.
                                                                                                                              • 0
                                                                                                                                В жаббере возвращаются error-ы при недоставке, вот только недоставка не всегда хорошо определяется по ряду причин.

                                                                                                                                Вот тред с деталями, если вам интересно — community.livejournal.com/ru_jabber/148403.html?thread=1986995#t2003635

                                                                                                                                Когда будет время, может быть оформлю выжимку из него отдельным постом.
                                                                                                                                • 0
                                                                                                                                  P.S. читать с самого начала страницы
                                                                                                                • НЛО прилетело и опубликовало эту надпись здесь
                                                                                                                  • +1
                                                                                                                    хороший IM, особенно хорошо в нем то, что ему могут радоваться пользователи всех распространенных операционных систем. Побольше бы таких программ.
                                                                                                                    • 0
                                                                                                                      Спасибо, за клиент, наверняка хорош.
                                                                                                                      Вопрос который меня гложит на протяжении долгого времени:
                                                                                                                      Почему не использовать например css для тем оформления?
                                                                                                                      • 0
                                                                                                                        Он использует вебкитовский движок, так что цсс используется. Правда когда тестировал возможности js было много неработающего, а так вполне можно верстать тему.
                                                                                                                        • 0
                                                                                                                          имеется ввиду темы для всего приложения или только для переписки в чате?

                                                                                                                          а импортировать историю из миранды, например, можно?
                                                                                                                          • 0
                                                                                                                            Используется css и в темах приложения, и в темах переписки. js в вебките тоже работает, благодаря ему, например, добавляются сообщения в лог.
                                                                                                                            Из миранды историю импортировать нельзя. Вообще есть вроде плагин менеджера истории, который позволяет импортировать историю из других клиентов, но именно миранду-то он и не поддерживает.
                                                                                                                            • 0
                                                                                                                              js работает, но когда я его тестил (это было правда давненько) в шаблонах ответов он обрабатывался криво. Т.е. если вставить скрипт в форму ответа, то при переписке будут наблюдаться странности в работе. Сейчас детально описать не могу, не помню за давностью времени.
                                                                                                                              • +1
                                                                                                                                я правильно понял, что всё UI это такие мини-браузерные окошки (webkit)?

                                                                                                                                и еще: не нашел как настроить expand\collapse групп по одному клику — два — неудобно :-(
                                                                                                                                • 0
                                                                                                                                  Нет, просто у Qt кастомизация виджетов тоже идёт при помощи css: doc.trolltech.com/4.5/stylesheet.html
                                                                                                                                  Для КЛ и рамок свои стили, документации пока нет. А по созданию стилей чата и форм окна чата на форуме есть доки.
                                                                                                                                  А expand/collapse пока не реализовано, будет в будущих версиях :)
                                                                                                                                  • 0
                                                                                                                                    А вы не думали интегрировать ваше приложение в air? Если нет и мысли об этом то почему?
                                                                                                                                    • 0
                                                                                                                                      Air — это что?
                                                                                                                                      • 0
                                                                                                                                        Air адоб, технология для кросс платформенных приложений…
                                                                                                                                      • 0
                                                                                                                                        А смысл интегрировать?