15 июня 2013 в 15:35

Разное → Как заблокировать торрент на 100%

Торрент — это проблема, над которой безуспешно бьются многие администраторы.
На сегодня я не встречал нигде ни одного нормально работающего решения по блокировке торрентов.

Вот мой авторский метод. Простой, эффективный, нересурсоемкий и работающий.
Блокирует исключительно только торрент-траффик.

Для роутера Mikrotik.

/ip firewall filter
add ac=drop ch=forward p2p=a
add ac=drop ch=forward in-int=e2 pr=udp cont=«d1:ad2:id20:» dst-port=1025-65535 packet-s=95-190
add ac=drop ch=forward in-int=e2 pr=tcp cont=«info_hash=» dst-port=2710,80


Опционально, т.е. не обязательно:

— Блокируем скачку .torrent файлов:
add ac=drop ch=forward cont="\r\nContent-Type: application/x-bittorrent" out-in=e2 pr=tcp src-p=80

— Блокируем локальный торрент:
add ac=drop ch=forward cont="\r\nInfohash: " in-in=e2 pr=udp dst-port=6771

e2 = ether2 — Внутренний LAN интерфейс.
Команды, там где "\r\n… "- вставлять только через консоль. Фильтрацию по IP дописать думаю сможете и сами.

По аналогии правила работают для любого нормального роутера, который умеет анализировать траффик.

Данные получены путем анализа траффика через сниффер CommView.

Есть также несколько других методов блокировки торрент-траффика.
1. Закрыть все, разрешить только нужные порты.
2. Закрыть доступ к торрент-сайтам.

Но:
В п.1. Нельзя открывать порты выше 1024. Иначе торрент траффик все-равно найдет этот порт.
Да и закрывается кроме торрента много чего нужного.
Нужно регулярно открывать по необходимости нужные порты.

В п.2. Все торрент-сайты не закроешь. Их очень много.
Остается возможность войти на торрент-сайт по IP-адресу.
Или просто в любом доступном месте скопировать magnet-ссылку или .torrent файл, например через онлайн web-proxy.
Да и ресурсоемкий этот метод.

Более подробное описание на английском языке в моем же посте на сайте Микротик
How to Block torrent 100%? Only 2 lines. It is solved

image